Bug 126065 - Dell PowerEdge 750 panic on mount root (sata)
Dell PowerEdge 750 panic on mount root (sata)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 14:03 EDT by Brian Brock
Modified: 2013-07-02 22:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:31:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full console log of 2.4.21-15.EL boot on Dell PowerEdge 750 (8.20 KB, text/plain)
2004-06-15 14:06 EDT, Brian Brock
no flags Details
output from `lspci -v` under 2.4.21-4.EL (3.96 KB, text/plain)
2004-06-15 14:08 EDT, Brian Brock
no flags Details

  None (edit)
Description Brian Brock 2004-06-15 14:03:46 EDT
Description of problem:
Dell PowerEdge 750 fails to mount /, and panics during boot.

Version-Release number of selected component (if applicable):
kernel-2.4.21-15.EL


does not occur with kernel-2.4.21-4.EL

tail of console log:

SCSI subsystem driver Revision: 1.00
ata_piix: combined mode detected
ata1: PATA max UDMA/33 cmd 0x1F0 ctl 0x3F6 bmdma 0xFEA0 irq 14
ata1: port disabled. ignoring.
ata2: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xFEA8 irq 15
ata2: port disabled. ignoring.
scsi0 : ata_piix
scsi1 : ata_piix
Journalled Block Device driver loaded
VFS: Cannot open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 00:00




this system also triggers bug #125994
Comment 1 Brian Brock 2004-06-15 14:06:07 EDT
Created attachment 101153 [details]
full console log of 2.4.21-15.EL boot on Dell PowerEdge 750

panic at end of log.
Comment 2 Brian Brock 2004-06-15 14:08:17 EDT
Created attachment 101155 [details]
output from `lspci -v` under 2.4.21-4.EL
Comment 3 Chuck Mead 2004-06-16 10:55:41 EDT
/me wonders if jgarzik should be the assignee for this bug.
Comment 4 Chuck Mead 2004-06-16 10:59:26 EDT
bah... mayhap /me should learn to read everything prior to commenting!
Comment 5 Chuck Mead 2004-06-16 14:49:32 EDT
Okay... just to be clear for all involved. RHEL3-U2 is required for
the class that the equipment in question is being built for. So... if
this means we have to take and respin a network install point with a
modded kernel so be it!

Whatever we're going to do we need to do it quickly as the class start
date of July 12 is rapidly approaching and with 40 uninstallable boxen
it's going to be tough to test anything or even conduct the class if
this bug is not fixed prior to the start date.
Comment 6 Chuck Mead 2004-06-17 16:55:37 EDT
Good news!

After some fussing around I took the patch that jgarzik gave me and
applied it to the U2 kernel. Built it and installed it to a vanilla
RHEL3 install on one of the new PE750's and it worked... network, SATA
all function just fine.

Since we cannot wait for U3 I am updating this box to U2 and then I
will respin a network install point on this box with the new kernel so
we can proceed with the project.
Comment 7 Ernie Petrides 2004-06-23 07:23:34 EDT
A fix for this problem has just been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-15.16.EL).
Comment 8 Mike McLean 2004-06-30 12:11:38 EDT
Has anyone verified this fix?
Comment 9 Brian Brock 2004-08-05 14:36:29 EDT
what's the name of the patch?
Comment 10 John Flanagan 2004-09-02 00:31:48 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.