Bug 1260837 - Q35 Machine type does not support S3 & S4
Q35 Machine type does not support S3 & S4
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Marcel Apfelbaum
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-07 22:36 EDT by quxiaoya
Modified: 2015-10-18 09:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-18 09:36:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description quxiaoya 2015-09-07 22:36:44 EDT
Description of problem:
when machine type is Q35, the S3 and S4 are not supported

Version-Release number of selected component (if applicable):
host info:
# uname -r
3.10.0-312.el7.x86_64
# rpm -qa | grep qemu
qemu-kvm-rhev-2.3.0-21.el7.x86_64

How reproducible:
100%

Steps to Reproduce:

1. boot command as follows: 
# /usr/libexec/qemu-kvm -M q35 -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1
2.
3.

Actual results:
VNC server running on `::1:5900'
qemu-kvm: Warning: global PIIX4_PM.disable_s3=1 not used
qemu-kvm: Warning: global PIIX4_PM.disable_s4=1 not used

Expected results:
Q35 support S3 & S4
Additional info:
Comment 3 Marcel Apfelbaum 2015-10-18 09:36:59 EDT
Hi,
This is not a bug.

Please use -global ICH9-LPC.disable_s3=0 -global ICH9-LPC.disable_s4=0 for Q35.
Also please use "0" to enable s3/s4 as the parameter is "disable" and a display device/driver that supports S3/S4.

If there are any specific issues, please open another BZ.
Thanks,
Marcel

Note You need to log in before you can comment on or make changes to this bug.