Bug 126084 - Inconsistency detected by ld.so
Inconsistency detected by ld.so
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 17:14 EDT by Richard Plana
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-17 17:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Plana 2004-06-15 17:14:36 EDT
Description of problem:
When trying to link some binaries to their appropriate libraries,
ld.so exits with the error:

Inconsistency detected by ld.so: rtld.c: 1192: dl_main: Assertion
`(void *) ph->p_vaddr == _rtld_local._dl_sysinfo_dso' failed!

There've been several sightings of this (as reported by Google), and
most involve upgrading to FC2. So far, none have attributed the
problem to FC2.

Version-Release number of selected component (if applicable):
glibc-2.3.3-27

How reproducible:
Always

Steps to Reproduce:
1. Download sample binaries like scratchbox/tools/bin/realpath from
http://www.scratchbox.org/download/files/sbox-releases/scratchbox-0.9.7.3.tar.gz
2. Try to execute the binary or execute 'ldd <binary>' to get the error
Comment 1 Jakub Jelinek 2004-06-17 17:43:17 EDT
This definitely is not FC2 glibc that prints this (our glibc rpms are
all built with -DNDEBUG).
So it looks like you are using older glibc which doesn't cope with
randomized vDSO.
As a workaround, you can boot with vdso=0 kernel cmdline option.
Or upgrade that glibc you're using to something newer (or older).
Problematic glibc's are from about April 2003 till March 2004 I believe.

Note You need to log in before you can comment on or make changes to this bug.