Bug 126088 - Arabic fonts are not displayed correctly under ooo
Summary: Arabic fonts are not displayed correctly under ooo
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
: 126092 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2004-06-15 21:27 UTC by Sameh Attia
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-24 15:51:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch for better arabic support in ooo (599 bytes, patch)
2004-06-15 22:01 UTC, Sameh Attia
no flags Details | Diff
modified spec file to solve the problem (16.83 KB, text/plain)
2004-06-16 12:19 UTC, Sameh Attia
no flags Details
Screenshot showing Arabic displayed wrongly in OOo Writer (56.85 KB, text/plain)
2004-06-19 17:48 UTC, Ossama Khayat
no flags Details

Description Sameh Attia 2004-06-15 21:27:37 UTC
Description of problem:
Arabic fonts in ooo are not displayed correctly. They get jammed.
Also opening arabic documents has the same effect.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. open owriter and choose an arabic font like KacstBook
2. start writing
Actual results:
characters get jammed

Expected results:
characters to be displayed correctly

Additional info:

Comment 1 Sameh Attia 2004-06-15 22:01:36 UTC
Created attachment 101175 [details]
Patch for better arabic support in ooo

Comment 2 Sameh Attia 2004-06-16 12:19:28 UTC
Created attachment 101184 [details]
modified spec file to solve the problem

this is another solution to the bug using ur spec file

Comment 3 Dan Williams 2004-06-16 13:17:11 UTC
Owen, comments?  This looks like more of a freetype issue.  OOo uses
the system freetype, not its internal one in our builds.

Comment 4 Mohamed Eldesoky 2004-06-16 13:34:19 UTC
Doing that exact patch fixed it.
You can get the SRPMs from here

Comment 5 Dan Williams 2004-06-16 14:42:28 UTC
which font/fonts are you using that display this behavior?

Comment 6 Sameh Attia 2004-06-17 06:15:26 UTC
All arabic fonts that r shipped with fc2. KacstBook for example is one
of them.

Comment 7 Ossama Khayat 2004-06-19 17:47:42 UTC
This is a real problem. After updating my freshly installed system, I
can't even type Arabic in OOo! You can see how Arabic is dispalyed in
Writer for example.

Comment 8 Ossama Khayat 2004-06-19 17:48:48 UTC
Created attachment 101263 [details]
Screenshot showing Arabic displayed wrongly in OOo Writer

Comment 9 Munzir Taha 2004-06-20 00:30:22 UTC
In Mandrake 10 I notice the same problem and downloading 
libfreetype6-2.1.7-4plf.i586.rpm fixed it. 
I still can't understand the bug well. Disabling bytecode interpreter will 
affect the output at small point sizes so it not a solution at all. besides the 
Mandrake plf rpm contains this engine. I got lost. 

Comment 10 Miloslav Trmac 2004-06-20 15:50:25 UTC
*** Bug 126092 has been marked as a duplicate of this bug. ***

Comment 11 Munzir Taha 2004-08-15 10:07:35 UTC
This bug is solved now. Check 
http://www.openoffice.org/issues/show_bug.cgi?id=32353 and 
for more details. The strange thing it turned out to be not related 
to libfreetype!! Still I wonder how come! You can test and verify 

Comment 12 Isam Bayazidi 2004-08-15 14:06:26 UTC
Munzir, it is related to libfreetype. As with the same version of OOo,
the problem appeared in Fedora Core 2, and Mandrake, but did not
appear in Debian. When I rebuild libfreetype RPM with the DEB
patchset, the result was that the problem disapeared. So, I tend to
believe it is related to Freetype. 

Comment 13 Dan Williams 2004-08-15 16:34:59 UTC
For my reference:  actual patch IZ is:

cvs diff -r1.46.10.6 -r1. source/gdi/salllayout.cxx

I'll try to get this patch into ooo-build and into a new 1.1.2 RPM
quite soon.  It should show up in 1.1.3 in any case.

Comment 14 Dan Williams 2004-08-15 16:39:27 UTC
Thanks for the pointer Munzir...

For my reference:  Patch is:

Comment 15 Mohamed Eldesoky 2004-09-19 11:07:24 UTC
Dan, made any use of the reference ??

Comment 16 Dan Williams 2004-09-19 14:38:57 UTC
yes, the patch will be in 1.1.2-5, which is ready-to-go, but blocked
on a PPC gcc issue right now that causes the build to fail early on.

Comment 17 Dan Williams 2004-09-24 15:51:05 UTC
Please test with the openoffice.org-1.1.2-5 RPMs in Rawhide.  If the
problem persists with that version, please reopen this bug.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.