Bug 126088 - Arabic fonts are not displayed correctly under ooo
Arabic fonts are not displayed correctly under ooo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
: 126092 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-15 17:27 EDT by Sameh Attia
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 11:51:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for better arabic support in ooo (599 bytes, patch)
2004-06-15 18:01 EDT, Sameh Attia
no flags Details | Diff
modified spec file to solve the problem (16.83 KB, text/plain)
2004-06-16 08:19 EDT, Sameh Attia
no flags Details
Screenshot showing Arabic displayed wrongly in OOo Writer (56.85 KB, text/plain)
2004-06-19 13:48 EDT, Ossama Khayat
no flags Details

  None (edit)
Description Sameh Attia 2004-06-15 17:27:37 EDT
Description of problem:
Arabic fonts in ooo are not displayed correctly. They get jammed.
Also opening arabic documents has the same effect.

Version-Release number of selected component (if applicable):
1.1.1-4

How reproducible:
always

Steps to Reproduce:
1. open owriter and choose an arabic font like KacstBook
2. start writing
3.
  
Actual results:
characters get jammed

Expected results:
characters to be displayed correctly

Additional info:
Comment 1 Sameh Attia 2004-06-15 18:01:36 EDT
Created attachment 101175 [details]
Patch for better arabic support in ooo
Comment 2 Sameh Attia 2004-06-16 08:19:28 EDT
Created attachment 101184 [details]
modified spec file to solve the problem

this is another solution to the bug using ur spec file
Comment 3 Dan Williams 2004-06-16 09:17:11 EDT
Owen, comments?  This looks like more of a freetype issue.  OOo uses
the system freetype, not its internal one in our builds.
Comment 4 Mohamed Eldesoky 2004-06-16 09:34:19 EDT
Doing that exact patch fixed it.
You can get the SRPMs from here
http://resala.linux-egypt.org/packages/freetype
Comment 5 Dan Williams 2004-06-16 10:42:28 EDT
which font/fonts are you using that display this behavior?
Comment 6 Sameh Attia 2004-06-17 02:15:26 EDT
All arabic fonts that r shipped with fc2. KacstBook for example is one
of them.
Comment 7 Ossama Khayat 2004-06-19 13:47:42 EDT
This is a real problem. After updating my freshly installed system, I
can't even type Arabic in OOo! You can see how Arabic is dispalyed in
Writer for example.
Comment 8 Ossama Khayat 2004-06-19 13:48:48 EDT
Created attachment 101263 [details]
Screenshot showing Arabic displayed wrongly in OOo Writer
Comment 9 Munzir Taha 2004-06-19 20:30:22 EDT
In Mandrake 10 I notice the same problem and downloading 
libfreetype6-2.1.7-4plf.i586.rpm fixed it. 
 
http://qa.mandrakesoft.com/show_bug.cgi?id=9664 
 
I still can't understand the bug well. Disabling bytecode interpreter will 
affect the output at small point sizes so it not a solution at all. besides the 
Mandrake plf rpm contains this engine. I got lost. 
Comment 10 Miloslav Trmac 2004-06-20 11:50:25 EDT
*** Bug 126092 has been marked as a duplicate of this bug. ***
Comment 11 Munzir Taha 2004-08-15 06:07:35 EDT
This bug is solved now. Check 
http://www.openoffice.org/issues/show_bug.cgi?id=32353 and 
http://www.openoffice.org/issues/show_bug.cgi?id=25565 
for more details. The strange thing it turned out to be not related 
to libfreetype!! Still I wonder how come! You can test and verify 
yourself. 
Comment 12 Isam Bayazidi 2004-08-15 10:06:26 EDT
Munzir, it is related to libfreetype. As with the same version of OOo,
the problem appeared in Fedora Core 2, and Mandrake, but did not
appear in Debian. When I rebuild libfreetype RPM with the DEB
patchset, the result was that the problem disapeared. So, I tend to
believe it is related to Freetype. 
Comment 13 Dan Williams 2004-08-15 12:34:59 EDT
For my reference:  actual patch IZ is:
http://www.openoffice.org/issues/show_bug.cgi?id=28567

---------
cvs diff -r1.46.10.6 -r1.46.10.6.8.1 source/gdi/salllayout.cxx
---------

I'll try to get this patch into ooo-build and into a new 1.1.2 RPM
quite soon.  It should show up in 1.1.3 in any case.
Comment 14 Dan Williams 2004-08-15 12:39:27 EDT
Thanks for the pointer Munzir...

For my reference:  Patch is:
http://gsl.openoffice.org/nonav/source/browse/gsl/vcl/source/gdi/sallayout.cxx?r2=1.46.10.6.8.1&r1=1.46.10.6&diff_format=c
Comment 15 Mohamed Eldesoky 2004-09-19 07:07:24 EDT
Dan, made any use of the reference ??
Comment 16 Dan Williams 2004-09-19 10:38:57 EDT
yes, the patch will be in 1.1.2-5, which is ready-to-go, but blocked
on a PPC gcc issue right now that causes the build to fail early on.
Comment 17 Dan Williams 2004-09-24 11:51:05 EDT
Please test with the openoffice.org-1.1.2-5 RPMs in Rawhide.  If the
problem persists with that version, please reopen this bug.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.