Bug 1260964 - Enable libccd for collision detection between e.g. cylinders
Enable libccd for collision detection between e.g. cylinders
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ode (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 06:08 EDT by Bahram Maleki-Fard
Modified: 2015-10-13 13:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: ode-0.13.1-4.fc23 ode-0.13.1-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 20:06:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bahram Maleki-Fard 2015-09-08 06:08:48 EDT
Description of problem:
A handful of collisions are only detected if ODE is built with libccd support:
http://ode-wiki.org/wiki/index.php?title=Manual:_Collision_Detection#Collision_tests_supported

Version-Release number of selected component (if applicable):
0.12-4.fc20

Additional info:
Seems to be valid for F21/F22/F23/Rawhide as well.

How to fix:
Enabling libccd colliders is done by adding:
* "libccd-devel" to BuildRequires
* "--enable-libccd" to both %configure steps
Comment 1 Hans de Goede 2015-09-09 06:45:47 EDT
Thanks for the bug report, an update fixing this is on its way.
Comment 2 Fedora Update System 2015-09-09 09:59:46 EDT
ode-0.13.1-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15457
Comment 3 Fedora Update System 2015-09-09 10:10:31 EDT
ode-0.13.1-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15458
Comment 4 Fedora Update System 2015-09-09 22:07:28 EDT
ode-0.13.1-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update ode'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15458
Comment 5 Fedora Update System 2015-09-10 01:51:31 EDT
ode-0.13.1-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update ode'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15457
Comment 6 Fedora Update System 2015-10-12 20:06:20 EDT
ode-0.13.1-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-10-13 13:03:33 EDT
ode-0.13.1-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.