Bug 1261053 - errata TPS tests fail on ppc64 aarch
errata TPS tests fail on ppc64 aarch
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 09:43 EDT by Roshni
Modified: 2015-09-14 14:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 14:47:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roshni 2015-09-08 09:43:58 EDT
Description of problem:
errata TPS tests fail on ppc64 aarch

Version-Release number of selected component (if applicable):
pki-ca-10.2.6-8.el7pki.noarch

How reproducible:
always

Steps to Reproduce:
1. run tps-rpmtest
2.
3.

Actual results:
=== UpgradeTest =====================
begin at 08/12/2015 22:35:02 on ppc64-7s-v1.ss.eng.bos.redhat.com

PkgState: oldCnt 3 ; oldInstCnt 2 ; newCnt 18 ; newInstCnt 0 ; none = 16 ; dropCnt 0 ; addCnt 15 ; strayCnt 0

  2 of  3 OLD,  0 of 18 NEW, and  0 STRAY packages are installed

TPSINFO: PkgState: Warning: not all the 'old' packages are actually installed.

old packages that are missing:
 old : missing : jss-debuginfo-4.2.6-35.el7.ppc64
doRpmCommand: rpm -U /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-kra-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc/nuxwdog-1.0.3-2.el7.ppc.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64/nuxwdog-client-java-1.0.3-2.el7.ppc64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-ca-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64/nuxwdog-1.0.3-2.el7.ppc64.rpm /mnt/redhat/brewroot/packages/tomcatjss/7.1.2/1.el7/noarch/tomcatjss-7.1.2-1.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc/nuxwdog-devel-1.0.3-2.el7.ppc.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/ppc64/jss-4.2.6-37.el7.ppc64.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64/nuxwdog-debuginfo-1.0.3-2.el7.ppc64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/ppc64/pki-tools-10.2.5-5.el7.ppc64.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/ppc64/jss-debuginfo-4.2.6-37.el7.ppc64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-base-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/ppc64/pki-core-debuginfo-10.2.5-5.el7.ppc64.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/ppc64/jss-javadoc-4.2.6-37.el7.ppc64.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64/nuxwdog-devel-1.0.3-2.el7.ppc64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/ppc64/pki-symkey-10.2.5-5.el7.ppc64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-server-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-javadoc-10.2.5-5.el7.noarch.rpm
doRpmCommand-result (4608): error: Failed dependencies:
	tomcat >= 7.0.40 is needed by tomcatjss-7.1.2-1.el7.noarch
	ldapjdk is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-client >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	tomcat >= 7.0.54 is needed by pki-server-10.2.5-5.el7.noarch

resteasy-base packages are not available under Server-optional repo to be installed

Expected results:
resteasy-base packages should be available under Server-optional repo to be installed

Additional info:
Comment 2 Roshni 2015-09-08 11:07:46 EDT
After installing al the dependency packages that were available the follwong is the result of tps-rpmtest

=== InstallTest =====================
Install test FAILED
Output from RPM Command:
error: Failed dependencies:
	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-client >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch


tps-srpmtest

REBUILD: FAIL for pki-core-10.2.5-5.el7.src.rpmBUILDLOG: pki-core-10.2.5-5.el7.src.rpm-ppc64-rebuild.log contains full details.  Reports from make and rpmbuild, with line numbers:
6-warning: group mockbuild does not exist - using root
7-warning: user mockbuild does not exist - using root
8-warning: group mockbuild does not exist - using root
9-warning: user mockbuild does not exist - using root
10-warning: group mockbuild does not exist - using root
11:error: Failed build dependencies:
12-	nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.ppc64
13-	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
14-	resteasy-base-client >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
15-	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
16-	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64

Last 20 lines of Build Log:
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
	nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.ppc64
	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
	resteasy-base-client >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
	resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
	resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
	svrcore-devel is needed by pki-core-10.2.5-5.el7.ppc64
Installing /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm
Building target platforms: ppc64
Building for target ppc64
Comment 3 Matthew Harmsen 2015-09-14 14:47:13 EDT
Per CS/DS Meeting of 09/14/2015 -- it was reported that since pki-core is only required for Idm, and since Idm has an exception to not be delivered on this platform, this bug is being closed as WONT FIX, and QE should waive TPS tests for this platform.

Note You need to log in before you can comment on or make changes to this bug.