Bug 1261057 - errata TPS tests fail on s390x arch
errata TPS tests fail on s390x arch
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 09:49 EDT by Roshni
Modified: 2015-09-14 14:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 14:47:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roshni 2015-09-08 09:49:09 EDT
Description of problem:
errata TPS tests fail on s390x arch

Version-Release number of selected component (if applicable):
pki-ca-10.2.6-8.el7pki.noarch

How reproducible:
always

Steps to Reproduce:
1. run tps-rpmtest
2.
3.

Actual results:
Upgrade test FAILED
Output from RPM Command:
error: Failed dependencies:
resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
resteasy-base-client >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
Old packages: /mnt/redhat/brewroot/packages/jss/4.2.6/35.el7/data/signed/fd431d51/s390x/jss-4.2.6-35.el7.s390x.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/35.el7/data/signed/fd431d51/s390x/jss-javadoc-4.2.6-35.el7.s390x.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/35.el7/data/signed/fd431d51/s390x/jss-debuginfo-4.2.6-35.el7.s390x.rpm
New packages: /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/s390x/nuxwdog-client-java-1.0.3-2.el7.s390x.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/s390x/nuxwdog-devel-1.0.3-2.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-kra-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/s390x/jss-debuginfo-4.2.6-37.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-ca-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/s390/nuxwdog-1.0.3-2.el7.s390.rpm /mnt/redhat/brewroot/packages/tomcatjss/7.1.2/1.el7/noarch/tomcatjss-7.1.2-1.el7.noarch.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/s390x/jss-4.2.6-37.el7.s390x.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/s390x/nuxwdog-1.0.3-2.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/s390x/pki-core-debuginfo-10.2.5-5.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/s390x/pki-symkey-10.2.5-5.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-base-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/s390x/pki-tools-10.2.5-5.el7.s390x.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/s390x/jss-javadoc-4.2.6-37.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-server-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/s390x/nuxwdog-debuginfo-1.0.3-2.el7.s390x.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-javadoc-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/s390/nuxwdog-devel-1.0.3-2.el7.s390.rpm
Packages on system after upgrade attempt - old -
jss-4.2.6-35.el7.s390x
jss-javadoc-4.2.6-35.el7.s390x


resteasy-base packages are not available under Server-optional repo

Expected results:
resteasy-base packages should be available under Server-optional repo

Additional info:
Comment 2 Roshni 2015-09-08 15:58:58 EDT
tps-srpmtest messages

--- REBUILD: pki-core-10.2.5-5.el7.src.rpm for s390x ---------------------
FAILED to rebuild /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm -- return code 256

REBUILD: FAIL for pki-core-10.2.5-5.el7.src.rpmBUILDLOG: pki-core-10.2.5-5.el7.src.rpm-s390x-rebuild.log contains full details.  Reports from make and rpmbuild, with line numbers:
6-warning: group mockbuild does not exist - using root
7-warning: user mockbuild does not exist - using root
8-warning: group mockbuild does not exist - using root
9-warning: user mockbuild does not exist - using root
10-warning: group mockbuild does not exist - using root
11:error: Failed build dependencies:
12-	nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.s390x
13-	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
14-	resteasy-base-client >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
15-	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
16-	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x

Last 20 lines of Build Log:
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
	nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.s390x
	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
	resteasy-base-client >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
	resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
	resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.s390x
	tomcatjss >= 7.1.0-6 is needed by pki-core-10.2.5-5.el7.s390x
	svrcore-devel is needed by pki-core-10.2.5-5.el7.s390x
Installing /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm
Building target platforms: s390x
Building for target s390x

===============
TPSRESULT: REBUILD: pki-core-10.2.5-5.el7.src.rpm for s390x Returning: FAIL
Comment 3 Matthew Harmsen 2015-09-14 14:47:39 EDT
Per CS/DS Meeting of 09/14/2015 -- it was reported that since pki-core is only required for Idm, and since Idm has an exception to not be delivered on this platform, this bug is being closed as WONT FIX, and QE should waive TPS tests for this platform.

Note You need to log in before you can comment on or make changes to this bug.