Bug 1261069 - errata TPS tests fail on ppc64le arch
errata TPS tests fail on ppc64le arch
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 10:05 EDT by Roshni
Modified: 2015-09-14 14:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 14:48:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roshni 2015-09-08 10:05:41 EDT
Description of problem:
errata TPS tests fail on ppc64le arch

Version-Release number of selected component (if applicable):
pki-ca-10.2.6-8.el7pki.noarch

How reproducible:
always

Steps to Reproduce:
1. run tps-rpmtest
2.
3.

Actual results:
=== UpgradeTest =====================
Upgrade test FAILED
Output from RPM Command:
error: Failed dependencies:
	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-client >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	perl(File::Slurp) is needed by pki-server-10.2.5-5.el7.noarch

Old packages: /mnt/redhat/brewroot/packages/nuxwdog/1.0.1/11.ael7b_1/data/signed/fd431d51/ppc64le/nuxwdog-client-java-1.0.1-11.ael7b_1.ppc64le.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.1/11.ael7b_1/data/signed/fd431d51/ppc64le/nuxwdog-devel-1.0.1-11.ael7b_1.ppc64le.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/35.ael7b/ppc64le/jss-debuginfo-4.2.6-35.ael7b.ppc64le.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.1/11.ael7b_1/data/signed/fd431d51/ppc64le/nuxwdog-1.0.1-11.ael7b_1.ppc64le.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/35.ael7b/ppc64le/jss-javadoc-4.2.6-35.ael7b.ppc64le.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.1/11.ael7b_1/data/signed/fd431d51/ppc64le/nuxwdog-debuginfo-1.0.1-11.ael7b_1.ppc64le.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/35.ael7b/ppc64le/jss-4.2.6-35.ael7b.ppc64le.rpm
New packages: /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-kra-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64le/nuxwdog-devel-1.0.3-2.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64le/nuxwdog-1.0.3-2.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64le/nuxwdog-debuginfo-1.0.3-2.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-ca-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/tomcatjss/7.1.2/1.el7/noarch/tomcatjss-7.1.2-1.el7.noarch.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/ppc64le/jss-debuginfo-4.2.6-37.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/ppc64le/jss-javadoc-4.2.6-37.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/ppc64le/nuxwdog-client-java-1.0.3-2.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-base-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/ppc64le/jss-4.2.6-37.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/ppc64le/pki-symkey-10.2.5-5.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/ppc64le/pki-tools-10.2.5-5.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/ppc64le/pki-core-debuginfo-10.2.5-5.el7.ppc64le.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-server-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-javadoc-10.2.5-5.el7.noarch.rpm
Packages on system after upgrade attempt - old -
	nuxwdog-client-java-1.0.1-11.ael7b_1.ppc64le

	jss-debuginfo-4.2.6-35.ael7b.ppc64le

	nuxwdog-devel-1.0.1-11.ael7b_1.ppc64le

	jss-javadoc-4.2.6-35.ael7b.ppc64le

	nuxwdog-1.0.1-11.ael7b_1.ppc64le

	nuxwdog-debuginfo-1.0.1-11.ael7b_1.ppc64le

	jss-4.2.6-35.ael7b.ppc64le

TPSRESULT: UpgradeTest Returning: FAIL


Expected results:


Additional info:
Comment 2 Roshni 2015-09-08 10:39:34 EDT
tps-srpmtest

FAILED to rebuild /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm -- return code 256
REBUILD: FAIL for pki-core-10.2.5-5.el7.src.rpm
BUILDLOG: pki-core-10.2.5-5.el7.src.rpm-ppc64-rebuild.log contains full details. Reports from make and rpmbuild, with line numbers:
1:error: Failed build dependencies:
2- ldapjdk is needed by pki-core-10.2.5-5.el7.ppc64
3- nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.ppc64
4- resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
5- resteasy-base-client >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
6- resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
Last 20 lines of Build Log:
error: Failed build dependencies:
ldapjdk is needed by pki-core-10.2.5-5.el7.ppc64
nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.ppc64
resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
resteasy-base-client >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-core-10.2.5-5.el7.ppc64
tomcatjss >= 7.1.0-6 is needed by pki-core-10.2.5-5.el7.ppc64
svrcore-devel is needed by pki-core-10.2.5-5.el7.ppc64
Installing /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm
Building target platforms: ppc64
Building for target ppc64
Comment 3 Matthew Harmsen 2015-09-14 14:48:00 EDT
Per CS/DS Meeting of 09/14/2015 -- it was reported that since pki-core is only required for Idm, and since Idm has an exception to not be delivered on this platform, this bug is being closed as WONT FIX, and QE should waive TPS tests for this platform.

Note You need to log in before you can comment on or make changes to this bug.