Bug 1261088 - errata TPS tests fail on aarch64 arch
errata TPS tests fail on aarch64 arch
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Harmsen
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 10:35 EDT by Roshni
Modified: 2015-09-08 14:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 14:06:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roshni 2015-09-08 10:35:31 EDT
Description of problem:
errata TPS tests fail on aarch64 arch

Version-Release number of selected component (if applicable):
pki-ca-10.2.6-8.el7pki.noarch

How reproducible:
always

Steps to Reproduce:
1. run tps-rpmtest
2.
3.

Actual results:
=== InstallTest =====================
Install test FAILED
Output from RPM Command:
error: Failed dependencies:
	java is needed by jss-4.2.6-37.el7.aarch64
	java-headless >= 1:1.7.0 is needed by pki-kra-10.2.5-5.el7.noarch
	java >= 1:1.6.0 is needed by nuxwdog-client-java-1.0.3-2.el7.aarch64
	jpackage-utils is needed by nuxwdog-client-java-1.0.3-2.el7.aarch64
	java-headless >= 1:1.7.0 is needed by pki-ca-10.2.5-5.el7.noarch
	java-headless >= 1:1.7.0 is needed by pki-tools-10.2.5-5.el7.aarch64
	jpackage-utils >= 0:1.7.5-10 is needed by pki-tools-10.2.5-5.el7.aarch64
	openldap-clients is needed by pki-tools-10.2.5-5.el7.aarch64
	apache-commons-lang is needed by tomcatjss-7.1.2-1.el7.noarch
	java is needed by tomcatjss-7.1.2-1.el7.noarch
	jpackage-utils >= 0:1.7.5-15 is needed by tomcatjss-7.1.2-1.el7.noarch
	tomcat >= 7.0.40 is needed by tomcatjss-7.1.2-1.el7.noarch
	jpackage-utils is needed by jss-javadoc-4.2.6-37.el7.aarch64
	java-headless >= 1:1.7.0 is needed by pki-symkey-10.2.5-5.el7.aarch64
	jpackage-utils >= 0:1.7.5-10 is needed by pki-symkey-10.2.5-5.el7.aarch64
	apache-commons-cli is needed by pki-base-10.2.5-5.el7.noarch
	apache-commons-codec is needed by pki-base-10.2.5-5.el7.noarch
	apache-commons-io is needed by pki-base-10.2.5-5.el7.noarch
	apache-commons-lang is needed by pki-base-10.2.5-5.el7.noarch
	apache-commons-logging is needed by pki-base-10.2.5-5.el7.noarch
	jakarta-commons-httpclient is needed by pki-base-10.2.5-5.el7.noarch
	java-headless >= 1:1.7.0 is needed by pki-base-10.2.5-5.el7.noarch
	javassist is needed by pki-base-10.2.5-5.el7.noarch
	jpackage-utils >= 0:1.7.5-10 is needed by pki-base-10.2.5-5.el7.noarch
	ldapjdk is needed by pki-base-10.2.5-5.el7.noarch
	python-ldap is needed by pki-base-10.2.5-5.el7.noarch
	python-requests >= 1.1.0-3 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-atom-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-client >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jackson-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxb-provider >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	resteasy-base-jaxrs-api >= 3.0.6-1 is needed by pki-base-10.2.5-5.el7.noarch
	xalan-j2 is needed by pki-base-10.2.5-5.el7.noarch
	xerces-j2 is needed by pki-base-10.2.5-5.el7.noarch
	xml-commons-apis is needed by pki-base-10.2.5-5.el7.noarch
	xml-commons-resolver is needed by pki-base-10.2.5-5.el7.noarch
	java-headless >= 1:1.7.0 is needed by pki-server-10.2.5-5.el7.noarch
	openldap-clients is needed by pki-server-10.2.5-5.el7.noarch
	perl(File::Slurp) is needed by pki-server-10.2.5-5.el7.noarch
	tomcat >= 7.0.54 is needed by pki-server-10.2.5-5.el7.noarch
	velocity is needed by pki-server-10.2.5-5.el7.noarch
	jpackage-utils is needed by pki-javadoc-10.2.5-5.el7.noarch

Old packages: 
New packages: /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/aarch64/jss-4.2.6-37.el7.aarch64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-kra-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/aarch64/nuxwdog-client-java-1.0.3-2.el7.aarch64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-ca-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/aarch64/pki-tools-10.2.5-5.el7.aarch64.rpm /mnt/redhat/brewroot/packages/tomcatjss/7.1.2/1.el7/noarch/tomcatjss-7.1.2-1.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/aarch64/nuxwdog-devel-1.0.3-2.el7.aarch64.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/aarch64/jss-javadoc-4.2.6-37.el7.aarch64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/aarch64/pki-symkey-10.2.5-5.el7.aarch64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-base-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/aarch64/nuxwdog-debuginfo-1.0.3-2.el7.aarch64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/aarch64/pki-core-debuginfo-10.2.5-5.el7.aarch64.rpm /mnt/redhat/brewroot/packages/jss/4.2.6/37.el7/aarch64/jss-debuginfo-4.2.6-37.el7.aarch64.rpm /mnt/redhat/brewroot/packages/nuxwdog/1.0.3/2.el7/aarch64/nuxwdog-1.0.3-2.el7.aarch64.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-server-10.2.5-5.el7.noarch.rpm /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/noarch/pki-javadoc-10.2.5-5.el7.noarch.rpm
Packages on system after install attempt - none -
TPSRESULT: InstallTest Returning: FAIL


tps-srpmtest

FAILED to rebuild /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm -- return code 256
REBUILD: FAIL for pki-core-10.2.5-5.el7.src.rpm
BUILDLOG: pki-core-10.2.5-5.el7.src.rpm-aarch64-rebuild.log contains full details. Reports from make and rpmbuild, with line numbers:
6-warning: group mockbuild does not exist - using root
7-warning: user mockbuild does not exist - using root
8-warning: group mockbuild does not exist - using root
9-warning: user mockbuild does not exist - using root
10-warning: group mockbuild does not exist - using root
11:error: Failed build dependencies:
12- nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.aarch64
13- jss >= 4.2.6-35 is needed by pki-core-10.2.5-5.el7.aarch64
14- tomcatjss >= 7.1.0-6 is needed by pki-core-10.2.5-5.el7.aarch64
15-Installing /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm
16-Building target platforms: aarch64
Last 20 lines of Build Log:
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
nuxwdog-client-java >= 1.0.1-11 is needed by pki-core-10.2.5-5.el7.aarch64
jss >= 4.2.6-35 is needed by pki-core-10.2.5-5.el7.aarch64
tomcatjss >= 7.1.0-6 is needed by pki-core-10.2.5-5.el7.aarch64
Installing /mnt/redhat/brewroot/packages/pki-core/10.2.5/5.el7/src/pki-core-10.2.5-5.el7.src.rpm
Building target platforms: aarch64
Building for target aarch64

Note You need to log in before you can comment on or make changes to this bug.