Bug 1261123 - Wesnoth doesn't build with boost 1.59
Wesnoth doesn't build with boost 1.59
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wesnoth (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 11:55 EDT by Bruno Wolff III
Modified: 2016-05-20 17:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-20 17:06:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2015-09-08 11:55:58 EDT
Description of problem:
Wesnoth tries to include boost/test/detail/unit_test_parameters.hpp which either has been renamed or removed since boost 1.58. I hope to look into this more soon, but want the problem logged in case others notice it and/or can look at it sooner.
Comment 1 Gwyn Ciesla 2015-09-08 12:42:30 EDT
I'm working in it as we speak.
Comment 2 Jan Kurik 2016-02-24 08:44:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Jonathan Wakely 2016-05-20 17:06:07 EDT
wesnoth builds OK now in f24 and rawhide (with boost 1.60)
Comment 4 Jonathan Wakely 2016-05-20 17:41:37 EDT
Oops, should have been NEXTRELEASE

Note You need to log in before you can comment on or make changes to this bug.