Bug 1261153 - [RFE] Add a mechanism to validate pre-reqs are satisfied before proceeding with install.
[RFE] Add a mechanism to validate pre-reqs are satisfied before proceeding wi...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: Derek Whatley
James Olin Oden
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 13:41 EDT by John Matthews
Modified: 2017-02-27 09:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2015-09-08 13:41:53 EDT
Description of problem:

This RFE came about when an install was performed on a host with only 8GB of memory.  The install proceeded and errors were seen during content synchronization.  The errors were likely the result of running with not enough memory available.

The minimal requirements are 12GB which is covered in documentation.

To help a user understand this and avoid a bad experience we'd like to enforce a check for pre-reqs when the ISO is running, in case they missed reading the minimal reqs in the docs.

Ideally we could execute a script to check:
 - RAM is sufficient
 - Hard Drive space is sufficient


Thinking is this would be part of the ISO installer, so it'd be integrated with anaconda.  If that proves too difficult we could add a warning in fusor-installer when first run.
Comment 1 Derek Whatley 2016-07-12 16:26:46 EDT
After some discussion with John Matthews, putting the requirement-check-script in fusor-installer and fusor-undercloud-installer rather than Anaconda seem to be the correct solution for now so that the ISO build process is not complicated.
Comment 7 Derek Whatley 2016-07-25 11:49:32 EDT
Made changes to fusor-installer and fusor-undercloud-installer to implement RFE.

fusor-installer PR: https://github.com/fusor/fusor-installer/pull/80

fusor-undercloud-installer PR: https://github.com/fusor/fusor-undercloud-installer/pull/43
Comment 8 Derek Whatley 2016-08-02 09:26:32 EDT
Bringing this back to MODIFIED so that it can be brought into the compose.
Comment 9 Derek Whatley 2016-08-05 11:05:47 EDT
Joseph Magen reported an issue with the RAM check detecting 0MB.

I switched the check over to "free -m" instead of "dmidecode -t 17" to prevent similar problems in the future.

https://github.com/fusor/fusor-undercloud-installer/pull/48
https://github.com/fusor/fusor-installer/pull/84
Comment 10 John Matthews 2016-08-05 13:18:14 EDT
Will be in compose 8/5
Comment 11 James Olin Oden 2016-08-08 15:28:19 EDT
Verified with QCI-1.0-RHEL-7-20160806.t.0

Tested:
- installing with 8Gb of RAM.
- installing with 2 cores.
- installing with 1 core.
- installing with too little disk storage.

All scenarios passed.
Comment 13 errata-xmlrpc 2016-09-13 12:21:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.