Bug 1261185 - Unable to connect RHEL7.2(beta) via XDMCP, getting black screen.
Unable to connect RHEL7.2(beta) via XDMCP, getting black screen.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
All Linux
high Severity high
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 15:59 EDT by amit yadav
Modified: 2015-10-06 11:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 11:33:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl -b -a log file (140.92 KB, text/x-vhdl)
2015-09-08 16:00 EDT, amit yadav
no flags Details
/var/log/messages and /var/log/gdm file (146.08 KB, application/x-gzip)
2015-09-08 16:00 EDT, amit yadav
no flags Details

  None (edit)
Description amit yadav 2015-09-08 15:59:10 EDT
Description of problem:

I have configured Xdmcp on RHEL7.2 Beta. when I try to connect this system from other RHEL/fedora system using "Xnest/Xephyr/Xorg", Sometimes I am getting black screen and sometime following error:


  "Oh no! Something has gone wrong." and "A problem has occurred and the system can't recover. Please log out and try again."

If I try to connect from Windows system using Cygwin/MobaXterm, I am getting above error.

Also getting following segfault messages in journalctl output:

Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com kernel: gnome-shell[3846]: segfault at 0 ip 00007fabf55956ac sp 00007ffc8f5eef50 error 4 in libmutter.so.0.0.0[7fabf5518000+ea000]
Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com abrt-hook-ccpp[4018]: Not saving repeating crash in '/usr/bin/gnome-shell'
Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com gnome-session[3587]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com polkitd[682]: Unregistered Authentication Agent for unix-session:c4 (system bus name :1.82, object path /org/freedesktop/PolicyKit1/Authentic
Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com gnome-session[3587]: gnome-session[3587]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com gnome-session[3587]: Unrecoverable failure in required component gnome-shell.desktop
Sep 09 01:15:22 dhcp234-17.gsslab.pnq.redhat.com abrt-server[3845]: Generating core_backtrace


Version-Release number of selected component (if applicable):
gnome-shell-3.14.4-26.el7.x86_64
mutter-3.14.4-11.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Configure XDMCP on RHEL7.2 system
2. Try to connect from other RHEL/Fedora system using below command:

    #   Xnest -query Server_ip :3

Actual results:

 Getting black screen or error "Oh no! Something has gone wrong."

Expected results:

 Should get gnome desktop

Additional info:

 Similar issue was discussed in follwing bug : 
  https://bugzilla.redhat.com/show_bug.cgi?id=1250128
Comment 1 amit yadav 2015-09-08 16:00:07 EDT
Created attachment 1071475 [details]
journalctl -b -a  log file
Comment 2 amit yadav 2015-09-08 16:00:52 EDT
Created attachment 1071476 [details]
/var/log/messages and /var/log/gdm file
Comment 5 Matthias Clasen 2015-09-29 11:10:17 EDT
I see

Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com gnome-session[3587]: gnome-session[3587]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Sep 09 01:15:21 dhcp234-17.gsslab.pnq.redhat.com gnome-session[3587]: Unrecoverable failure in required component gnome-shell.desktop
Sep 09 01:15:22 dhcp234-17.gsslab.pnq.redhat.com abrt-server[3845]: Generating core_backtrace

in the logs. It would be really useful to get the coredump that abrt collected there.
Comment 6 Matthias Clasen 2015-10-05 15:19:39 EDT
ping. Any chance to get that coredump ?
Comment 7 Michal Domonkos 2015-10-06 05:36:16 EDT
So I can't reproduce this.

Neither with the 7.2 Beta nor with the latest nightly.  The GDM session never crashes for me and I always get the greeter when connecting with Xephyr.

With Xnest the story is a bit different as I do get the "Oh no!" screen, however it still doesn't crash.  I think the reason for that is this:

  gdm[1335]: Xlib:  extension "RANDR" missing on display "192.168.122.1:99".

which is probably expected (it also happens on 7.1) and certainly not related to this bug.

One thing that comes to mind is that maybe the reporter was using a headless machine and thus hit the bug 1243856 and bug 1241559.  That issue is already fixed so if that was the case, we can consider this one to be fixed, too.
Comment 8 Michal Domonkos 2015-10-06 05:57:16 EDT
> machine and thus hit the bug 1243856 and bug 1241559.  That issue is already

s/1241559/1212702/
Comment 9 Matthias Clasen 2015-10-06 09:09:50 EDT
Thanks for the retesting, Michal. If we can't reproduce, we can't fix.
Comment 10 Matthias Clasen 2015-10-06 10:25:36 EDT
Xnest is not supported. Unless this bug reproduces with Xephyr, we can close it.
Comment 11 Michal Domonkos 2015-10-06 10:59:30 EDT
(In reply to Matthias Clasen from comment #10)
> Xnest is not supported. Unless this bug reproduces with Xephyr, we can close
> it.

Nope, Xephyr is not affected.  Let's close.

Note You need to log in before you can comment on or make changes to this bug.