Bug 1261202 - Grub default entry is not updated when installing new kernel.
Grub default entry is not updated when installing new kernel.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 17:48 EDT by kakoskin
Modified: 2015-11-18 14:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 14:09:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/grubby (1.29 KB, text/plain)
2015-09-08 17:48 EDT, kakoskin
no flags Details
/boot/efi/EFI/fedora/grub.cfg (8.89 KB, text/plain)
2015-09-08 17:49 EDT, kakoskin
no flags Details

  None (edit)
Description kakoskin 2015-09-08 17:48:26 EDT
Created attachment 1071516 [details]
/var/log/grubby

Description of problem:
Grub default boot entry is  not updated when installing a new kernel. Original kernel installed when installing system remains as the default. 

Version-Release number of selected component (if applicable):
grubby-8.40-2.fc23.x86_64

kernel-4.2.0-1.fc23.x86_64
kernel-4.2.0-300.fc23.x86_64

How reproducible:
Install Fedora 23 Beta TC4 Workstation Live and update it with dnf. On boot observe that older of two kernels is the default. 

Actual results:
Older of two kernels is the default. 

Expected results:
New kernel is the default.

Additional info:
This is similar to https://bugzilla.redhat.com/show_bug.cgi?id=1242315 on Fedora 22.
Comment 1 kakoskin 2015-09-08 17:49:47 EDT
Created attachment 1071517 [details]
/boot/efi/EFI/fedora/grub.cfg
Comment 2 kakoskin 2015-11-18 14:09:12 EST
This seems to have been working since the public release of Fedora 23.

Note You need to log in before you can comment on or make changes to this bug.