Bug 1261243 - Win10-64 guest bsod with >=16 virtio-net-pci nic cards
Win10-64 guest bsod with >=16 virtio-net-pci nic cards
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On: 1263193
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-08 23:10 EDT by huiqingding
Modified: 2017-06-13 00:00 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-13 00:00:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of win10-64 guest cannot boot (45.94 KB, image/png)
2015-09-09 04:36 EDT, huiqingding
no flags Details

  None (edit)
Description huiqingding 2015-09-08 23:10:58 EDT
Description of problem:
Boot guest with >=16 virtio-net-pci nic cards, win10-64 guest bsod with error "DRIVE_IRQL_NOT_LESS_OR_EQUAL".

Version Release number of selected component (if applicable):
100%

How reproducible:
qemu-kvm-rhev-2.3.0-22.el7.x86_64
kernel-3.10.0-313.el7.x86_64

Steps to Reproduce:
1. boot win10-64 guest with 29 virtio-net-pci nic cards
# /usr/libexec/qemu-kvm -M pc-i440fx-rhel7.2.0 -vga qxl -spice disable-ticketing,port=5931 -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1,maxcpus=240 -name rhel7 -uuid 745fe449-aac8-29f1-0c2d-5042a707263b -drive file=gluster://10.66.144.35/vol1/win10-64.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=4e:63:28:bc:b1:25  -monitor stdio -serial unix:/tmp/tty0,server,nowait \
-netdev tap,id=hostnet1,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet1,id=virtio-net-pci1,mac=4e:63:28:bc:b1:01 \
-netdev tap,id=hostnet2,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet2,id=virtio-net-pci2,mac=4e:63:28:bc:b1:02 \
-netdev tap,id=hostnet3,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:b1:03 \
-netdev tap,id=hostnet4,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet4,id=virtio-net-pci4,mac=4e:63:28:bc:b1:04 \
-netdev tap,id=hostnet5,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet5,id=virtio-net-pci5,mac=4e:63:28:bc:b1:05 \
-netdev tap,id=hostnet6,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet6,id=virtio-net-pci6,mac=4e:63:28:bc:b1:06 \
-netdev tap,id=hostnet7,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet7,id=virtio-net-pci7,mac=4e:63:28:bc:b1:07 \
-netdev tap,id=hostnet8,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet8,id=virtio-net-pci8,mac=4e:63:28:bc:b1:08 \
-netdev tap,id=hostnet9,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet9,id=virtio-net-pci9,mac=4e:63:28:bc:b1:09 \
-netdev tap,id=hostnet10,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet10,id=virtio-net-pci10,mac=4e:63:28:bc:b1:0A \
-netdev tap,id=hostnet11,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet11,id=virtio-net-pci11,mac=4e:63:28:bc:b1:0B \
-netdev tap,id=hostnet12,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet12,id=virtio-net-pci12,mac=4e:63:28:bc:b1:0C \
-netdev tap,id=hostnet13,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet13,id=virtio-net-pci13,mac=4e:63:28:bc:b1:0D \
-netdev tap,id=hostnet14,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet14,id=virtio-net-pci14,mac=4e:63:28:bc:b1:0E \
-netdev tap,id=hostnet15,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet15,id=virtio-net-pci15,mac=4e:63:28:bc:b1:0F \
-netdev tap,id=hostnet16,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet16,id=virtio-net-pci16,mac=4e:63:28:bc:b1:10 \
-netdev tap,id=hostnet17,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet17,id=virtio-net-pci17,mac=4e:63:28:bc:b1:11 \
-netdev tap,id=hostnet18,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet18,id=virtio-net-pci18,mac=4e:63:28:bc:b1:12 \
-netdev tap,id=hostnet19,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet19,id=virtio-net-pci19,mac=4e:63:28:bc:b1:13 \
-netdev tap,id=hostnet20,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet20,id=virtio-net-pci20,mac=4e:63:28:bc:b1:14 \
-netdev tap,id=hostnet21,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet21,id=virtio-net-pci21,mac=4e:63:28:bc:b1:15 \
-netdev tap,id=hostnet22,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet22,id=virtio-net-pci22,mac=4e:63:28:bc:b1:16 \
-netdev tap,id=hostnet23,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet23,id=virtio-net-pci23,mac=4e:63:28:bc:b1:17 \
-netdev tap,id=hostnet24,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet24,id=virtio-net-pci24,mac=4e:63:28:bc:b1:18 \
-netdev tap,id=hostnet25,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet25,id=virtio-net-pci25,mac=4e:63:28:bc:b1:19 \
-netdev tap,id=hostnet26,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet26,id=virtio-net-pci26,mac=4e:63:28:bc:b1:1A \
-netdev tap,id=hostnet27,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet27,id=virtio-net-pci27,mac=4e:63:28:bc:b1:1B \
-netdev tap,id=hostnet28,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet28,id=virtio-net-pci28,mac=4e:63:28:bc:b1:1C \

2.
3.

Actual results:
after step1, win10-64 guest bsod with error "DRIVE_IRQL_NOT_LESS_OR_EQUAL"

Expected results:


Additional info:
Comment 3 juzhang 2015-09-08 23:30:12 EDT
Hi Huding,

Please identify whether it is a regression bz.

Best Regards,
Junyi
Comment 4 huiqingding 2015-09-09 04:36:12 EDT
Created attachment 1071617 [details]
screenshot of win10-64 guest cannot boot

(In reply to juzhang from comment #3)
> Hi Huding,
> 
> Please identify whether it is a regression bz.
> 
> Best Regards,
> Junyi

I test the latest RHEL7.1.z qemu-kvm-rhev
qemu-kvm-rhev-2.1.2-23.el7_1.9.x86_64

The win10-64 guest cannot boot with error "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED"

The command line is:
/usr/libexec/qemu-kvm -M pc-i440fx-rhel7.0.0 -vga qxl -spice disable-ticketing,port=5931 -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1,maxcpus=240 -name rhel7 -uuid 745fe449-aac8-29f1-0c2d-5042a707263b -drive file=gluster://10.66.144.35/vol1/win10-64.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=4e:63:28:bc:b1:25  -monitor stdio -serial unix:/tmp/tty0,server,nowait \
Comment 5 Karen Noel 2015-09-09 07:14:36 EDT
Please specify the version of virtio-win drivers installed.

Does this happen with a RHEL 7.2 guest or another Windows version? Or, is this specific to Win10?

Yan, Does this seem like a qemu or virtio-win issue? Please fix the component if virtio-win. Thanks.
Comment 6 Yan Vugenfirer 2015-09-09 10:03:10 EDT
Doesn't look like related to the driver.


The only processor that is active is this one:
2: kd> kb
RetAddr           : Args to Child                                                           : Call Site
fffff800`c2d9477e : ffffe000`00000300 00000000`00001000 00000000`00000000 ffffe000`00000000 : nt!ExAllocatePoolWithTag+0x743
fffff800`c2d967f7 : ffffe000`44a4d408 ffffe000`441ff500 00000000`c0000001 ffffe000`44a4d408 : ACPI!GetObjectPathNoLock+0x6e
fffff800`c2d968c3 : ffffe000`441ff5c8 ffffe000`44a4d478 00000000`00000000 ffffe000`441ff600 : ACPI!AMLIGetNameSpaceObjectPath+0x47
fffff800`c2dfff16 : ffffe000`441ff5c8 ffffd001`a4f4d20c 00000000`00000010 00000000`00000000 : ACPI!ACPIAmliBuildObjectPathname+0x2b
fffff800`c2df5caa : 00000000`00000000 ffffd001`a4f4d249 00000000`00000000 ffffd001`00000009 : ACPI!LinkNodeFindByName+0x46
fffff800`c2d96475 : 00000000`000007ff ffffd001`a4c40000 ffffd001`a4f4d598 00000000`00000801 : ACPI!PcisuppGetRoutingInfo+0xad02
fffff800`c2dedbf4 : fffff800`c2dd9120 ffffc001`a4241000 ffffc001`a4243080 ffffc001`a4243080 : ACPI!LinkNodeCrackPrt+0x7d
fffff800`c2df1a7e : ffffc001`a4243080 ffffc001`a4247901 ffffc001`a4243030 ffffc001`00000000 : ACPI!IrqArbGetNextAllocationRange+0x114
fffff800`c2ded832 : 00000000`00000000 00000000`000000ba ffffc001`9f4ca248 fffff800`c2dd9120 : ACPI!ArbAllocateEntry+0x8e
fffff800`c2dedac7 : ffffd001`a4f4d6b0 00000000`0000001d 00000000`00000000 00000000`0000001d : ACPI!ArbTestAllocation+0x122
fffff800`c2df18eb : fffff800`c2dd9120 00000000`00000000 00000000`00000000 00000000`00000000 : ACPI!IrqArbTestAllocation+0x27
fffff801`875e0f6a : ffffc001`9f517df0 ffffd001`a4f4d7c0 ffffd001`a4f4d7c0 fffff801`875e5e1b : ACPI!ArbArbiterHandler+0x8b
fffff801`875e0dca : 01d0ea58`fdb27382 ffffc001`a4208000 00000000`c0000001 00000000`0000001d : nt!IopTestConfiguration+0x82
fffff801`875e0d42 : 00000000`00000000 ffffc001`a4208000 00000000`0000001d 00000000`00000000 : nt!PnpFindBestConfigurationWorker+0x66
fffff801`876ecfd8 : 00000000`00000000 ffffd001`a4f4d7e9 00000000`00000001 ffffc001`9f569000 : nt!PnpFindBestConfiguration+0x2e
fffff801`87684d56 : ffffc001`9f5266a0 ffffe000`45334a50 00000000`c0000001 ffffc001`9f5266a0 : nt!PnpRebalance+0x1f0
fffff801`87565f66 : 00000000`00000006 ffffe000`45333060 ffffc001`9f526520 ffffc001`9f5266e0 : nt! ?? ::NNGAKEGL::`string'+0x61006
fffff801`874c3fb9 : ffffe000`4575b230 ffffd001`a4f4da10 00000000`00000000 ffffe000`00000000 : nt!PnpProcessAssignResources+0x122
fffff801`8760c0c7 : 00000000`00000000 00000000`00000001 00000000`00000000 fffff801`874c496e : nt!PipProcessDevNodeTree+0xa1
fffff801`8713969a : 00000001`00000003 00000000`00000000 fffff801`873ad240 00000000`00000000 : nt!PiProcessStartSystemDevices+0x87
fffff801`870e96a9 : ffffe000`43d3d040 fffff801`873ad240 fffff801`8744a340 ffffe000`456834f8 : nt!PnpDeviceActionWorker+0x436
fffff801`87157e88 : 044ea5c0`36405932 00000000`00000080 fffff801`8744a340 ffffe000`43d3d040 : nt!ExpWorkerThread+0xe9
fffff801`871c4326 : fffff801`873d4180 ffffe000`43d3d040 ffffe000`43d3e040 53cede5b`97119a9e : nt!PspSystemThreadStartup+0x58
00000000`00000000 : ffffd001`a4f4e000 ffffd001`a4f48000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16


Looks like resource allocation (IRQ) by the OS. The crash is bad memory access:
DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000008, value 0 = read operation, 1 = write operation
Arg4: 0000000000000000, address which referenced memory



How many devices were present in the command line? 

I see 29 virtio-net devices and I see in the dump file 29 mini ports:3: kd> !ndiskd.miniports
    MiniDriver         Miniport            Name                                 
    ffffe00045760aa0   ffffe000457ba1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe0004579a1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe0004579c1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe0004579e1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457a01a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457a21a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457a41a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457a61a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457a81a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457aa1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457ac1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457ae1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457b01a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457b21a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457b41a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457b61a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457b81a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000457981a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455a11a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455a31a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455a51a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455a71a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455a91a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455ab1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455ad1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455af1a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455b11a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455b31a0    Red Hat VirtIO Ethernet Adapter
    ffffe00045760aa0   ffffe000455b51a0    Red Hat VirtIO Ethernet Adapter

And I see two ide devices. Could it be there were more PCI devices and we run out of the place on the bus (32 devices)?
Comment 7 Yan Vugenfirer 2015-09-09 10:03:53 EDT
Please post full command line used to reproduce the crash.
Comment 8 huiqingding 2015-09-09 21:48:26 EDT
(In reply to Yan Vugenfirer from comment #7)
> Please post full command line used to reproduce the crash.

Hi, Yan,

The command line is as comment #0
# /usr/libexec/qemu-kvm -M pc-i440fx-rhel7.2.0 -vga qxl -spice disable-ticketing,port=5931 -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1,maxcpus=240 -name rhel7 -uuid 745fe449-aac8-29f1-0c2d-5042a707263b -drive file=gluster://10.66.144.35/vol1/win10-64.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=4e:63:28:bc:b1:25  -monitor stdio -serial unix:/tmp/tty0,server,nowait \
-netdev tap,id=hostnet1,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet1,id=virtio-net-pci1,mac=4e:63:28:bc:b1:01 \
-netdev tap,id=hostnet2,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet2,id=virtio-net-pci2,mac=4e:63:28:bc:b1:02 \
-netdev tap,id=hostnet3,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:b1:03 \
-netdev tap,id=hostnet4,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet4,id=virtio-net-pci4,mac=4e:63:28:bc:b1:04 \
-netdev tap,id=hostnet5,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet5,id=virtio-net-pci5,mac=4e:63:28:bc:b1:05 \
-netdev tap,id=hostnet6,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet6,id=virtio-net-pci6,mac=4e:63:28:bc:b1:06 \
-netdev tap,id=hostnet7,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet7,id=virtio-net-pci7,mac=4e:63:28:bc:b1:07 \
-netdev tap,id=hostnet8,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet8,id=virtio-net-pci8,mac=4e:63:28:bc:b1:08 \
-netdev tap,id=hostnet9,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet9,id=virtio-net-pci9,mac=4e:63:28:bc:b1:09 \
-netdev tap,id=hostnet10,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet10,id=virtio-net-pci10,mac=4e:63:28:bc:b1:0A \
-netdev tap,id=hostnet11,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet11,id=virtio-net-pci11,mac=4e:63:28:bc:b1:0B \
-netdev tap,id=hostnet12,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet12,id=virtio-net-pci12,mac=4e:63:28:bc:b1:0C \
-netdev tap,id=hostnet13,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet13,id=virtio-net-pci13,mac=4e:63:28:bc:b1:0D \
-netdev tap,id=hostnet14,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet14,id=virtio-net-pci14,mac=4e:63:28:bc:b1:0E \
-netdev tap,id=hostnet15,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet15,id=virtio-net-pci15,mac=4e:63:28:bc:b1:0F \
-netdev tap,id=hostnet16,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet16,id=virtio-net-pci16,mac=4e:63:28:bc:b1:10 \
-netdev tap,id=hostnet17,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet17,id=virtio-net-pci17,mac=4e:63:28:bc:b1:11 \
-netdev tap,id=hostnet18,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet18,id=virtio-net-pci18,mac=4e:63:28:bc:b1:12 \
-netdev tap,id=hostnet19,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet19,id=virtio-net-pci19,mac=4e:63:28:bc:b1:13 \
-netdev tap,id=hostnet20,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet20,id=virtio-net-pci20,mac=4e:63:28:bc:b1:14 \
-netdev tap,id=hostnet21,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet21,id=virtio-net-pci21,mac=4e:63:28:bc:b1:15 \
-netdev tap,id=hostnet22,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet22,id=virtio-net-pci22,mac=4e:63:28:bc:b1:16 \
-netdev tap,id=hostnet23,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet23,id=virtio-net-pci23,mac=4e:63:28:bc:b1:17 \
-netdev tap,id=hostnet24,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet24,id=virtio-net-pci24,mac=4e:63:28:bc:b1:18 \
-netdev tap,id=hostnet25,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet25,id=virtio-net-pci25,mac=4e:63:28:bc:b1:19 \
-netdev tap,id=hostnet26,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet26,id=virtio-net-pci26,mac=4e:63:28:bc:b1:1A \
-netdev tap,id=hostnet27,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet27,id=virtio-net-pci27,mac=4e:63:28:bc:b1:1B \
-netdev tap,id=hostnet28,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet28,id=virtio-net-pci28,mac=4e:63:28:bc:b1:1C \
Comment 9 Yan Vugenfirer 2015-09-24 07:15:56 EDT
1. Please specify the version of the virtio-win drivers

2. Please provide the exact steps that led to the crash. (For example how exactly the driver was installed or VM was booted before the crash).

Thanks.
Comment 10 Yan Vugenfirer 2015-09-27 06:39:05 EDT
Does this crash happen with other Windows versions as well?

Thanks.
Comment 11 huiqingding 2015-09-29 03:04:24 EDT
(In reply to Yan Vugenfirer from comment #9)
> 1. Please specify the version of the virtio-win drivers

Comment #0 use virtio-win-prewhql-0.1-109
 
> 2. Please provide the exact steps that led to the crash. (For example how
> exactly the driver was installed or VM was booted before the crash).
1. boot win10-64 guest with one virtio-net-pci nic
2. inside guest, install the virtio-net-pci driver of virtio-win-prewhql-0.1-109
3. shutdown the guest
4. boot win10-64 guest with 29 virtio-net-pci nics, win10-64 guest bsod with error "DRIVE_IRQL_NOT_LESS_OR_EQUAL" as comment #0


Update virtio-win-prewhql-0.1-109 to virtio-win-prewhql-0.1-110, win10-64 guest can boot normally with 29 virtio-net-pci nics.
Comment 12 huiqingding 2015-09-29 03:35:24 EDT
(In reply to Yan Vugenfirer from comment #10)
> Does this crash happen with other Windows versions as well?


I test win8.1-64 guest with 29 virtio-net-pci nics, also crash as comment #0, the driver is virtio-win-prewhql-0.1-109.

Update virtio-win-prewhql-0.1-109 to virtio-win-prewhql-0.1-110, win8.1-64 guest can boot normally with 29 virtio-net-pci nics.
Comment 13 Yan Vugenfirer 2015-09-29 04:06:29 EDT
(In reply to huiqingding from comment #12)
> (In reply to Yan Vugenfirer from comment #10)
> > Does this crash happen with other Windows versions as well?
> 
> 
> I test win8.1-64 guest with 29 virtio-net-pci nics, also crash as comment
> #0, the driver is virtio-win-prewhql-0.1-109.
> 
> Update virtio-win-prewhql-0.1-109 to virtio-win-prewhql-0.1-110, win8.1-64
> guest can boot normally with 29 virtio-net-pci nics.

Can you please test original scenario with 110 as well?

Thanks.
Comment 14 Yan Vugenfirer 2015-09-30 10:28:24 EDT
Works on 110. Solved by the fix for BZ#1263193.
Comment 15 huiqingding 2015-10-08 04:10:17 EDT
Reproduce this bug using the following version:
qemu-kvm-rhev-2.3.0-28.el7.x86_64
kernel-3.10.0-320.el7.x86_64
virtio-win-prewhql-109

Steps to Reproduce:
1. boot win10-64 guest with 29 virtio-net-pci nic cards
# /usr/libexec/qemu-kvm -M pc-i440fx-rhel7.2.0 -vga qxl -spice disable-ticketing,port=5931 -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1,maxcpus=240 -name rhel7 -uuid 745fe449-aac8-29f1-0c2d-5042a707263b -drive file=/home/win10.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=4e:63:28:bc:b1:25  -monitor stdio -serial unix:/tmp/tty0,server,nowait \
-netdev tap,id=hostnet1,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet1,id=virtio-net-pci1,mac=4e:63:28:bc:b1:01 \
-netdev tap,id=hostnet2,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet2,id=virtio-net-pci2,mac=4e:63:28:bc:b1:02 \
-netdev tap,id=hostnet3,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:b1:03 \
-netdev tap,id=hostnet4,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet4,id=virtio-net-pci4,mac=4e:63:28:bc:b1:04 \
-netdev tap,id=hostnet5,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet5,id=virtio-net-pci5,mac=4e:63:28:bc:b1:05 \
-netdev tap,id=hostnet6,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet6,id=virtio-net-pci6,mac=4e:63:28:bc:b1:06 \
-netdev tap,id=hostnet7,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet7,id=virtio-net-pci7,mac=4e:63:28:bc:b1:07 \
-netdev tap,id=hostnet8,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet8,id=virtio-net-pci8,mac=4e:63:28:bc:b1:08 \
-netdev tap,id=hostnet9,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet9,id=virtio-net-pci9,mac=4e:63:28:bc:b1:09 \
-netdev tap,id=hostnet10,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet10,id=virtio-net-pci10,mac=4e:63:28:bc:b1:0A \
-netdev tap,id=hostnet11,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet11,id=virtio-net-pci11,mac=4e:63:28:bc:b1:0B \
-netdev tap,id=hostnet12,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet12,id=virtio-net-pci12,mac=4e:63:28:bc:b1:0C \
-netdev tap,id=hostnet13,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet13,id=virtio-net-pci13,mac=4e:63:28:bc:b1:0D \
-netdev tap,id=hostnet14,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet14,id=virtio-net-pci14,mac=4e:63:28:bc:b1:0E \
-netdev tap,id=hostnet15,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet15,id=virtio-net-pci15,mac=4e:63:28:bc:b1:0F \
-netdev tap,id=hostnet16,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet16,id=virtio-net-pci16,mac=4e:63:28:bc:b1:10 \
-netdev tap,id=hostnet17,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet17,id=virtio-net-pci17,mac=4e:63:28:bc:b1:11 \
-netdev tap,id=hostnet18,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet18,id=virtio-net-pci18,mac=4e:63:28:bc:b1:12 \
-netdev tap,id=hostnet19,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet19,id=virtio-net-pci19,mac=4e:63:28:bc:b1:13 \
-netdev tap,id=hostnet20,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet20,id=virtio-net-pci20,mac=4e:63:28:bc:b1:14 \
-netdev tap,id=hostnet21,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet21,id=virtio-net-pci21,mac=4e:63:28:bc:b1:15 \
-netdev tap,id=hostnet22,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet22,id=virtio-net-pci22,mac=4e:63:28:bc:b1:16 \
-netdev tap,id=hostnet23,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet23,id=virtio-net-pci23,mac=4e:63:28:bc:b1:17 \
-netdev tap,id=hostnet24,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet24,id=virtio-net-pci24,mac=4e:63:28:bc:b1:18 \
-netdev tap,id=hostnet25,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet25,id=virtio-net-pci25,mac=4e:63:28:bc:b1:19 \
-netdev tap,id=hostnet26,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet26,id=virtio-net-pci26,mac=4e:63:28:bc:b1:1A \
-netdev tap,id=hostnet27,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet27,id=virtio-net-pci27,mac=4e:63:28:bc:b1:1B \
-netdev tap,id=hostnet28,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet28,id=virtio-net-pci28,mac=4e:63:28:bc:b1:1C \

Actual results:
after step1, win10-64 guest bsod with error "DRIVE_IRQL_NOT_LESS_OR_EQUAL"
Comment 16 huiqingding 2015-10-08 04:31:29 EDT
Verify this bug using the following version:
qemu-kvm-rhev-2.3.0-28.el7.x86_64
kernel-3.10.0-322.el7.x86_64
virtio-win-prewhql-110

The steps as comment #15, boot win10-64 guest with 29 virtio-net-pci cards, guest can boot normally.
Comment 17 juzhang 2015-10-08 23:47:03 EDT
According to comment15 and comment16, set this issue as verified.

Note You need to log in before you can comment on or make changes to this bug.