Bug 1261258 - Typo found during translation "The VM ${VmName} has sanpshots that must be collapsed."
Typo found during translation "The VM ${VmName} has sanpshots that must be co...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Allon Mureinik
Eyal Shenitzky
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 01:25 EDT by Yuko Katabami
Modified: 2016-03-10 10:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:53:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
amureini: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46206 master MERGED engine: Fix typo: sanpshots->snapshots Never
oVirt gerrit 46220 ovirt-engine-3.6 MERGED engine: Fix typo: sanpshots->snapshots Never

  None (edit)
Description Yuko Katabami 2015-09-09 01:25:07 EDT
Description of problem:
I found a minor typo while translating the UI strings.

Version-Release number of selected component (if applicable): 3.6


How reproducible: 100%


Actual results:
Cannot ${action} ${type}. The VM ${VmName} has sanpshots that must be collapsed.

Expected results:
Cannot ${action} ${type}. The VM ${VmName} has snapshots that must be collapsed.

Additional info:

File: AppErrors
Resource ID: ACTION_TYPE_FAILED_IMPORT_CLONE_NOT_COLLAPSED
Comment 1 Kevin Alon Goldblatt 2015-10-25 08:57:31 EDT
(In reply to Yuko Katabami from comment #0)
> Description of problem:
> I found a minor typo while translating the UI strings.
> 
> Version-Release number of selected component (if applicable): 3.6
> 
> 
> How reproducible: 100%
> 
> 
> Actual results:
> Cannot ${action} ${type}. The VM ${VmName} has sanpshots that must be
> collapsed.
> 
> Expected results:
> Cannot ${action} ${type}. The VM ${VmName} has snapshots that must be
> collapsed.
> 
> Additional info:
> 
> File: AppErrors
> Resource ID: ACTION_TYPE_FAILED_IMPORT_CLONE_NOT_COLLAPSED

Hi,

Can you please provide the steps to reproduce this scenario.

Thaks
Comment 2 Yuko Katabami 2015-10-25 16:56:09 EDT
Unfortunately I do not have steps to reproduce this.
It was found during translation in Zanata.

Might be involved in VM importing?
Comment 3 Kevin Alon Goldblatt 2015-10-26 11:56:30 EDT
Used the following code:
----------------------------------
rhevm-3.6.0-0.18.el6.noarch
vdsm-4.17.8-1.el7ev.noarch


I tried to reproduce a scenario to generate the string by importing VM's but this string is not displayed. Without specific steps to reproduce this issue I cannot Verify this BZ. Please advise
Comment 4 Yuko Katabami 2015-10-26 18:14:34 EDT
I can only verify that the strings pushed to zanata is now fixed in both ovirt-3.6 and master versions:

Cannot ${action} ${type}. The VM ${VmName} has snapshots that must be collapsed.

@Einav, Would this be good enough to move the status  VERIFIED?
Comment 5 Allon Mureinik 2015-10-29 04:52:11 EDT
(In reply to Kevin Alon Goldblatt from comment #3)
> Used the following code:
> ----------------------------------
> rhevm-3.6.0-0.18.el6.noarch
> vdsm-4.17.8-1.el7ev.noarch
> 
> 
> I tried to reproduce a scenario to generate the string by importing VM's but
> this string is not displayed. Without specific steps to reproduce this issue
> I cannot Verify this BZ. Please advise

This error should occur when you attempt to import a VM that has a snapshot(s), without cloning it, and one or more of the images already exist on the target storage domain.
Comment 6 Eyal Shenitzky 2015-11-11 04:35:03 EST
After the following steps the bug isn't reproduce:

1. create vm with disk
2. create 2 snapshot
3. add 2 additional disks
4. create another snapshot
5. export the vm
6. remove the vm but don't remove the disk attached to him
7. import the vm without cloning it

this is the massage received by the engine:

Cannot import VM. The Storage Domain already contains the target disk(s).

engine-version:
3.6.0.3-0.1.el6

vdsm:
4.17.9-1.el7ev

there is no farther steps for us to do.
Comment 7 Sandro Bonazzola 2015-11-27 02:53:58 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.