Bug 126130 - libswigpl.so and libswigpy.so not included in latest swig
libswigpl.so and libswigpy.so not included in latest swig
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: swig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: 1295826
  Show dependency treegraph
 
Reported: 2004-06-16 10:37 EDT by Bob Gustafson
Modified: 2016-02-09 10:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-22 23:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-06-16 10:37:02 EDT
Description of problem:

 Subversion (still) needs libswigpl.so and libswigpy.so. Either this
requirement is in error, or the required libraryies have dropped out
of later versions of swig

Version-Release number of selected component (if applicable):

  swig-0-1.3.21-2.i386.hdr

How reproducible:

  Have noticed it for the last week or so - trying to update

Steps to Reproduce:

1. I tried various things - culminating in rpm -e swig and subversion
2. then see command listing and output below

Actual results:

[root@hoho2 user1]# rpm -e subversion
[root@hoho2 user1]# rpm -e swig
[root@hoho2 user1]# yum install subversion\*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
swig-0-1.3.21-2.i386.hdr  100% |=========================|  11 kB    00:00
Resolving dependencies
....Unable to satisfy dependencies
Package subversion-perl needs libswigpl.so, this is not available.
Package subversion needs libswigpy.so, this is not available.
[root@hoho2 user1]# ls -l /usr/lib/libswigpl.so*
ls: /usr/lib/libswigpl.so*: No such file or directory
[root@hoho2 user1]# ls -l /usr/lib/libswigpy.so*
ls: /usr/lib/libswigpy.so*: No such file or directory
[root@hoho2 user1]#


Expected results:

  clean install of swig and subversion

Additional info:

 Fedora 2 - pretty much updated from devel as of the moment
Comment 1 Bob Gustafson 2004-06-16 10:51:56 EDT
Veriations on the same theme:

[root@hoho2 user1]# yum install swig\*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[install: swig 1.3.21-2.i386]
Is this ok [y/N]: y
Downloading Packages
Getting swig-1.3.21-2.i386.rpm
swig-1.3.21-2.i386.rpm    100% |=========================| 1.0 MB    00:06
Running test transaction:
ERROR: Multiple different specifications for /usr/sbin/imapd 
(system_u:object_r:imapd_exec_t and system_u:object_r:inetd_child_exec_t).
Test transaction complete, Success!
ERROR: Multiple different specifications for /usr/sbin/imapd 
(system_u:object_r:imapd_exec_t and system_u:object_r:inetd_child_exec_t).
swig 100 % done 1/1
Installed:  swig 1.3.21-2.i386
Transaction(s) Complete
[root@hoho2 user1]# ls -l /usr/lib/libswigpl.so*
lrwxrwxrwx  1 root root    18 Jun 16 09:45 /usr/lib/libswigpl.so ->
libswigpl.so.0.0.0
lrwxrwxrwx  1 root root    18 Jun 16 09:45 /usr/lib/libswigpl.so.0 ->
libswigpl.so.0.0.0
-rwxr-xr-x  1 root root 11588 May 19 06:34 /usr/lib/libswigpl.so.0.0.0
[root@hoho2 user1]# yum install subversion\*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
....Unable to satisfy dependencies
Package subversion-perl needs libswigpl.so, this is not available.
Package subversion needs libswigpy.so, this is not available.
[root@hoho2 user1]#
Comment 2 Bob Gustafson 2004-06-22 23:38:45 EDT
Whatever and whoever - subversion or swig folks - thanks much

Works for me now
Comment 3 Avi Kivity 2005-01-02 14:06:21 EST
the bug is back, with swig 0:1.3.23-2: 
 
  # rpm -ql swig | grep -c lib 
  0 
 
please fix. 
Comment 4 Max Bowsher 2005-01-16 04:06:25 EST
The return of this bug with swig 1.3.23 is seperately filed as bug 142970

Note You need to log in before you can comment on or make changes to this bug.