Bug 126131 - Sorting order is wrong for leading underscores
Sorting order is wrong for leading underscores
Status: CLOSED DUPLICATE of bug 103539
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bash (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 10:43 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-06-16 10:43:45 EDT
Description of problem:
When using UTF8, underscores should come before letters.

# printenv LANG
en_US.UTF-8

# ls
apple
_banana
cabbage

# LANG=C ls
_banana
apple
cabbage
Comment 1 Tim Waugh 2004-06-25 07:02:03 EDT
This is not to do with UTF-8, but with en_US, and the collation
behaviour you see is correct and mandated by POSIX.  See also bug #76328.

*** This bug has been marked as a duplicate of 103539 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.