Bug 1261329 - wrong command in /etc/cron.daily/docker-logrotate
wrong command in /etc/cron.daily/docker-logrotate
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.1
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
: 1261312 1261321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 03:53 EDT by Zhang Jiajun
Modified: 2016-01-26 20:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1264196 (view as bug list)
Environment:
Last Closed: 2016-01-07 16:51:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhang Jiajun 2015-09-09 03:53:08 EDT
Description of problem:

In /etc/cron.daily/docker-logrotate which is created after installing docker-logrotate, there is a following setting:

  exec $(docker exec $id logrotate -s /var/log/logstatus /etc/logrotate.conf > /dev/null 2&>1)

It should be:

  exec $(docker exec $id logrotate -s /var/log/logstatus /etc/logrotate.conf > /dev/null 2>&1)

Additional info:

# rpm -qa |grep docker
docker-1.7.1-108.el7.x86_64
docker-selinux-1.7.1-108.el7.x86_64
docker-logrotate-1.7.1-108.el7.x86_64
docker-registry-0.9.1-4.el7.x86_64
Comment 2 Daniel Walsh 2015-09-09 10:01:57 EDT
*** Bug 1261321 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2015-09-09 10:02:23 EDT
*** Bug 1261312 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Walsh 2015-10-29 11:50:27 EDT
Fixed in docker-1.9
Comment 7 Lokesh Mandvekar 2015-10-29 13:48:15 EDT
This has been fixed in 1.8.2 itself. Let me include that in the errata.

Note You need to log in before you can comment on or make changes to this bug.