Bug 1261355 - running commands with virt-builder doesn't work
running commands with virt-builder doesn't work
Status: CLOSED DUPLICATE of bug 1261377
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 04:07 EDT by Jan Sedlák
Modified: 2015-09-09 04:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 04:32:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2015-09-09 04:07:21 EDT
Description of problem:
virt-builder doesn't run any commands on system that it is building - if you specify command to run with --run-command or packages to install with --install (or even --selinux-relabel), it doesn't fail during building that image, but it doesn't seem to run that command either.

For example, if you run:

virt-builder -x -v fedora-22 --install vim --root-password password:weakpassword -o disk.img

vim isn't installed on output disk image.

Version-Release number of selected component (if applicable):
virt-builder 1.30.1fedora=22,release=2.fc22,libvirt

How reproducible:
Always.

Steps to Reproduce:
1. Run 'virt-builder -x -v fedora-22 --install vim --root-password password:weakpassword -o disk.img'
2. Boot disk.img: 'qemu-kvm disk.img'
3. Observe that vim isn't installed.
Comment 1 Pino Toscano 2015-09-09 04:32:07 EDT

*** This bug has been marked as a duplicate of bug 1261377 ***

Note You need to log in before you can comment on or make changes to this bug.