Bug 1261377 - running commands with virt-builder doesn't work
running commands with virt-builder doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
: 1261318 1261323 1261327 1261330 1261334 1261355 1261361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 04:23 EDT by Jan Sedlák
Modified: 2015-11-09 12:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 12:43:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-builder output (105.11 KB, text/plain)
2015-09-09 04:24 EDT, Jan Sedlák
no flags Details

  None (edit)
Description Jan Sedlák 2015-09-09 04:23:54 EDT
Description of problem:
virt-builder doesn't run any commands on system that it is building - if you specify command to run with --run-command or packages to install with --install (or even --selinux-relabel), it doesn't fail during building that image, but it doesn't seem to run that command either.

For example, if you run:

virt-builder -x -v fedora-22 --install vim --root-password password:weakpassword -o disk.img

vim isn't installed on output disk image.

Version-Release number of selected component (if applicable):
virt-builder 1.30.1fedora=22,release=2.fc22,libvirt

How reproducible:
Always.

Steps to Reproduce:
1. Run 'virt-builder -x -v fedora-22 --install vim --root-password password:weakpassword -o disk.img'
2. Boot disk.img: 'qemu-kvm disk.img'
3. Observe that vim isn't installed.
Comment 1 Jan Sedlák 2015-09-09 04:24:20 EDT
Created attachment 1071612 [details]
virt-builder output
Comment 2 Pino Toscano 2015-09-09 04:31:41 EDT
*** Bug 1261318 has been marked as a duplicate of this bug. ***
Comment 3 Pino Toscano 2015-09-09 04:31:45 EDT
*** Bug 1261323 has been marked as a duplicate of this bug. ***
Comment 4 Pino Toscano 2015-09-09 04:31:50 EDT
*** Bug 1261327 has been marked as a duplicate of this bug. ***
Comment 5 Pino Toscano 2015-09-09 04:31:53 EDT
*** Bug 1261330 has been marked as a duplicate of this bug. ***
Comment 6 Pino Toscano 2015-09-09 04:32:03 EDT
*** Bug 1261334 has been marked as a duplicate of this bug. ***
Comment 7 Pino Toscano 2015-09-09 04:32:07 EDT
*** Bug 1261355 has been marked as a duplicate of this bug. ***
Comment 8 Pino Toscano 2015-09-09 04:32:10 EDT
*** Bug 1261361 has been marked as a duplicate of this bug. ***
Comment 9 Pino Toscano 2015-09-09 04:36:36 EDT
The upstream fix (commit d875346ad441d4762455ea1b41d57ad6174d9b63, backported to the stable-1.30 branch as 42734a3954a4d4eb370dfa051f788812b2b23984) caused that regression.
This has been fixed upstream with commit 7bdb3e0df93ef9cdee11b40a85056e609de45414, backported to stable-1.30 as commit 16d92df4d86fb944a4331870fe7bfd0b8aa57a5e; the fixes are part of libguestfs >= 1.31.4 and >= 1.30.2.
Comment 10 Richard W.M. Jones 2015-09-09 05:26:28 EDT
Yes, this was definitely broken in 1.30.1-2, but fixed in
this testing release:

https://bodhi.fedoraproject.org/updates/FEDORA-2015-15401 (f22)
https://bodhi.fedoraproject.org/updates/FEDORA-2015-15420 (f23)
Comment 11 Pino Toscano 2015-11-09 12:43:32 EST
Fixed versions available in Fedora already:
- https://bodhi.fedoraproject.org/updates/FEDORA-2015-f7b0c57297 (f22)
- https://bodhi.fedoraproject.org/updates/FEDORA-2015-15420 (f23)
so closing.

Note You need to log in before you can comment on or make changes to this bug.