Bug 1261380 - Planner can't load drools files in OSGI environment when drools score function is used
Planner can't load drools files in OSGI environment when drools score functio...
Status: VERIFIED
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: OptaPlanner (Show other bugs)
6.2.0
Unspecified Unspecified
urgent Severity urgent
: ER4
: 6.2.0
Assigned To: Geoffrey De Smet
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 04:29 EDT by jvahala
Modified: 2016-04-28 01:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PLANNER-387 Critical Resolved Add optional classloader parameter into SolverFactory methods, especially for OSGi 2015-10-19 06:29 EDT

  None (edit)
Description jvahala 2015-09-09 04:29:49 EDT
Description of problem:
OSGI support was implemented in 6.2, but planner can't handle one (or more) drools files. Problem is, that planner itself is in different bundle than those files. next classloader is needed.  

original jira: 
https://issues.jboss.org/browse/PLANNER-358

setting severity as urgent, since this is crucial feature for some customers.
Comment 2 Geoffrey De Smet 2015-09-10 08:26:29 EDT
Fixed for community 6.3.0.Final through jira PLANNER-387 (see commit url's linked in that jira)
Comment 3 jvahala 2015-10-14 09:52:14 EDT
Can't be verified until 1268233 is resolved
Comment 4 Geoffrey De Smet 2015-10-16 09:10:02 EDT
1268233 resolved
Comment 5 jvahala 2015-10-19 06:31:00 EDT
Tests are passing, putting on verified with 6.2.0ER4

Note You need to log in before you can comment on or make changes to this bug.