Bug 1261406 - anaconda blocking shutdown
anaconda blocking shutdown
Status: CLOSED DUPLICATE of bug 1290046
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 05:18 EDT by Harald Hoyer
Modified: 2016-08-10 08:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 09:56:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2015-09-09 05:18:16 EDT
Provision storageqe-11.rhts.eng.bos.redhat.com normally.

Installation is with iSCSI drives. Seems like the network is torn down, before the umount succeeded.


dracut Warning: Killing all remaining processes
dracut Warning: Cannot umount /oldroot
dracut Warning: Blocking umount of /oldroot [11026] /bin/umount /mnt/sysimage/boot -n
dracut Warning: lrwxrwxrwx. 1 root 0 0 Sep 9 08:31 /proc/11026/exe -> /oldroot/usr/bin/umount
dracut Warning: total 0
dracut Warning: lr-x------. 1 root 0 64 Sep 9 08:21 0 -> /oldsys/dev/null
dracut Warning: lrwx------. 1 root 0 64 Sep 9 08:21 1 -> socket:[95028]
dracut Warning: lrwx------. 1 root 0 64 Sep 9 08:21 2 -> socket:[95028]
dracut Warning: Blocking umount of /oldroot [11051] /bin/umount /mnt/sysimage -n
dracut Warning: lrwxrwxrwx. 1 root 0 0 Sep 9 08:31 /proc/11051/exe -> /oldroot/usr/bin/umount
dracut Warning: total 0
dracut Warning: lr-x------. 1 root 0 64 Sep 9 08:26 0 -> /oldsys/dev/null
dracut Warning: lrwx------. 1 root 0 64 Sep 9 08:26 1 -> socket:[104111]
dracut Warning: lrwx------. 1 root 0 64 Sep 9 08:26 2 -> socket:[104111]
Comment 2 David Shea 2015-09-18 16:25:24 EDT
Anaconda just calls systemctl reboot (or shutdown) at the end of the installation. systemd is the one umounting filesystems and tearing down networks.
Comment 3 Lukáš Nykrýn 2015-09-21 06:19:54 EDT
Do the mount units have correct ordering dependencies? Can you get a shutdown log from that machine?
Comment 4 Harald Hoyer 2015-11-16 04:27:42 EST
(In reply to David Shea from comment #2)
> Anaconda just calls systemctl reboot (or shutdown) at the end of the
> installation. systemd is the one umounting filesystems and tearing down
> networks.

does it do that with "--no-block" ??
Comment 5 Lukáš Nykrýn 2016-01-11 09:51:32 EST
This looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1290046 . Anaconda guys can you please look at that?
Comment 6 David Shea 2016-01-11 09:56:33 EST

*** This bug has been marked as a duplicate of bug 1290046 ***
Comment 7 Sujith 2016-01-11 23:07:27 EST
Hi David,
BZ#1290046 seems to be an internal one.
Can it be opened to us?

Thanks,
Sujith
Comment 8 David Shea 2016-01-12 09:28:08 EST
(In reply to Sujith from comment #7)
> Hi David,
> BZ#1290046 seems to be an internal one.
> Can it be opened to us?
> 
> Thanks,
> Sujith

I've requested that bug 1290046 be opened to Dell.

Note You need to log in before you can comment on or make changes to this bug.