Bug 1261425 - lxdm prevents from locking my screen by Super+L keys after loging in, as I did it sucessfully if using GDM as displaymanager
lxdm prevents from locking my screen by Super+L keys after loging in, as I di...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lxdm (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 06:01 EDT by Joachim Backes
Modified: 2015-09-09 10:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 10:26:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2015-09-09 06:01:25 EDT
Description of problem:
I runned gdm as displaymanager and chosed Super+L as shortcut to lock my screen. Then I installed and used lxdm as displaymanager, but then it's no more possible to lock the screen by Super+L key after logging in. I can get rid of this by re-using gdm as displaymanager, 

Version-Release number of selected component (if applicable):
lxdm-0.5.1-6.D20150806git17ac3772.fc23.x86_64

How reproducible:
always

Steps to Reproduce:
1.see description
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mamoru TASAKA 2015-09-09 10:26:41 EDT
It is just LXDE does not support it, not a bug.

By the way, although I have not tried myself, there is a way to customize shortcut key on LXDE (via openbox) when you use LXDE desktop:
http://www.archlinuxuser.com/2014/04/create-lxde-fn-key-shortcut-for.html

However I guess the above won't work when you use LXDM for login manager and use desktop environment other than LXDE. If you want to make lxdm support this, please file a RFE for the upsteam.

Note You need to log in before you can comment on or make changes to this bug.