Bug 126143 - up2date fails with message "exploded!"
up2date fails with message "exploded!"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 14:02 EDT by Shariful Anam Shuman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 15:04:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shariful Anam Shuman 2004-06-16 14:02:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
I have installed RH AS 3.0 (Update 2) on a box and also registered
with RHN. I can login and can see that this system is entitled for
"Management". But when I run "up2date", it starts fetching package
headers and then simply quits by saying "exploded!". I can see that
the fetched headers are in /var/spool/up2date. It always fails
after/during sendmail-cf-8.12.11-3.3 header. Same thing happens with
"up2date --nox -l". I have updated up2date from the installed version
to 4.2.16-1 by downloading and installing it manually. But the same
problem persists.

I am using an http proxy server. Also I have "retrieveOnly" enabled.



Version-Release number of selected component (if applicable):
up2date-4.2.16-1

How reproducible:
Always

Steps to Reproduce:
1. Runing up2date either from X or from text console
    

Actual Results:  up2date quits (crashes? no exception or anything)
saying "exploded!"


Expected Results:  Provide with a list of available packages for updating.


Additional info:

[ root@metamorphosis:0:~# ] up2date --nox -l

Fetching package list for channel: rhel-i386-as-3...
########################################

Fetching Obsoletes list for channel: rhel-i386-as-3...

Fetching rpm headers...
exploded!#######################
[ root@metamorphosis:0:~# ] ######
Comment 1 Adrian Likins 2004-06-17 14:51:09 EDT
Theres a header somewhere in your /var/spool/up2date directory
that is causing the rpm header load to fail. 

Try `rm -rf /var/spool/up2date/*.hdr`

Comment 2 Shariful Anam Shuman 2004-06-19 10:43:53 EDT
Tried removing just the last .hdr file from /var/spool/up2date and ran
up2date, with same result. Removed all files from /var/spool/up2date
and got the following two outputs on two sequential attempts:

[ root@metamorphosis:2:~# ] up2date --nox -l

Fetching package list for channel: rhel-i386-as-3...
SSL exception (-1, 'Unexpected EOF')
########################################

Fetching Obsoletes list for channel: rhel-i386-as-3...
########################################

Fetching rpm headers...
SSL exception (-1, 'Unexpected EOF')
SSL exception (-1, 'Unexpected EOF')
[ root@metamorphosis:2:~# ] up2date --nox -l

Fetching package list for channel: rhel-i386-as-3...
########################################

Fetching Obsoletes list for channel: rhel-i386-as-3...

Fetching rpm headers...
exploded!#####
exploded!
SSL exception (-1, 'Unexpected EOF')
exploded!
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 60, in run
  File "up2dateBatch.py", line 101, in __findPackagesToUpdate
  File "packageList.py", line 549, in getPackagesToInstall
  File "packageList.py", line 578, in __skipPackages
  File "packageList.py", line 599, in __skipFiles
  File "packageList.py", line 638, in buildHeaderList
  File "headers.py", line 37, in __getitem__
  File "headers.py", line 42, in __retrievePackage
  File "rpcServer.py", line 112, in doCall
  File "repoDirector.py", line 31, in getHeader
  File "rpmSource.py", line 210, in getHeader
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 102, in getHeader
    rpmSourceUtils.saveHeader(hdr)
  File "rpmSourceUtils.py", line 24, in saveHeader
TypeError: unsubscriptable object
Comment 3 Ian Laurie 2004-07-22 04:17:19 EDT
I'm also running up2date-4.2.16-1.  Running it in the GUI causes it to
silently die with no error info sent to the log file.

From the command line I get this:

server# up2date --nox -l
 
Fetching package list for channel: rhel-i386-ws-3...
########################################
 
Fetching package list for channel: rhel-i386-ws-3-devsuite...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-ws-3...
 
Fetching Obsoletes list for channel: rhel-i386-ws-3-devsuite...
 
Fetching rpm headers...
exploded!#################
Segmentation fault
server#

Seems like a similar problem.  The last header downloaded was:

    php-odbc-4.3.2-11.1.ent.i386.hdr

it did NOT retrieve:
   
    php-pgsql-4.3.2-11.1.ent.i386.hdr

After rm'ing the last one downloaded
(php-odbc-4.3.2-11.1.ent.i386.hdr) I got this:

server# up2date --nox -l
 
Fetching package list for channel: rhel-i386-ws-3...
########################################
 
Fetching package list for channel: rhel-i386-ws-3-devsuite...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-ws-3...
 
Fetching Obsoletes list for channel: rhel-i386-ws-3-devsuite...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
php                                     4.3.2          11.1.ent      
   i386
php-imap                                4.3.2          11.1.ent      
   i386
php-ldap                                4.3.2          11.1.ent      
   i386
php-mysql                               4.3.2          11.1.ent      
   i386
php-odbc                                4.3.2          11.1.ent      
   i386
php-pgsql                               4.3.2          11.1.ent      
   i386
 
server#

I was then also able to run it in GUI mode and do an update without
problems.  Seems to be intolerant of a corrupted header, whereas it
should delete it and download it again.

Note You need to log in before you can comment on or make changes to this bug.