Bug 1261490 - Sandbox does not work with browser over tunnelled X connection
Sandbox does not work with browser over tunnelled X connection
Status: CLOSED DUPLICATE of bug 1261938
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 08:32 EDT by Andrew Haley
Modified: 2015-10-13 02:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 02:21:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Haley 2015-09-09 08:32:23 EDT
Description of problem:

If you do "ssh foo" then "sandbox -X -H sehome -T tmp -t sandbox_web_t firefox" it fails with
avc: denied { name_connect } for pid=28872 comm="Xephyr"

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1. ssh foo
2. sandbox -X -H sehome -T tmp -t sandbox_web_t firefox


Raw Audit Messages
type=AVC msg=audit(1441028831.509:1552): avc:  denied  { name_connect } for  pid=28872 comm="Xephyr" dest=6010 scontext=unconfined_u:unconfined_r:sandbox_xserver_t:s0:c653,c929 tcontext=system_u:object_r:xserver_port_t:s0 tclass=tcp_socket


type=SYSCALL msg=audit(1441028831.509:1552): arch=x86_64 syscall=connect success=no exit=EACCES a0=0 a1=263a850 a2=10 a3=7ffe50ee3874 items=0 ppid=28863 pid=28872 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=34 comm=Xephyr exe=/usr/bin/Xephyr subj=unconfined_u:unconfined_r:sandbox_xserver_t:s0:c653,c929 key=(null)

Hash: Xephyr,sandbox_xserver_t,xserver_port_t,tcp_socket,name_connect
Comment 2 Miroslav Grepl 2015-09-11 03:28:05 EDT
What does

$ rpm -q libcap-ng 

show you?
Comment 3 Andrew Haley 2015-09-11 04:30:35 EDT
(In reply to Miroslav Grepl from comment #2)
> What does
> 
> $ rpm -q libcap-ng 
> 
> show you?

libcap-ng-0.7.3-5.el7.x86_64
Comment 4 Miroslav Grepl 2015-10-13 02:21:27 EDT

*** This bug has been marked as a duplicate of bug 1261938 ***

Note You need to log in before you can comment on or make changes to this bug.