Bug 126153 - gtk-doc installs gtk-doc.pc in /usr/share/pkgconfig
gtk-doc installs gtk-doc.pc in /usr/share/pkgconfig
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk-doc (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 15:14 EDT by Nickolay V. Shmyrev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 15:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nickolay V. Shmyrev 2004-06-16 15:14:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
What is the reason for that? It fully brokes build of gtk-doc-based
documentation in the system. gtk-doc.pc should be installed in
/usr/lib/pkgconfig

Version-Release number of selected component (if applicable):
gtk-doc-1.2.1

How reproducible:
Always

Steps to Reproduce:
Install package

Additional info:
Comment 1 Nickolay V. Shmyrev 2004-06-16 15:33:00 EDT
Now found, that patched Fedora pkgconfig-0.15 search also in
/usr/share/pkgconfig. It there is high need to add
/usr/share/pkgconfig directory, please, add dependency from package
pkgconfig-0.15-1
Comment 2 Matthias Clasen 2004-06-16 15:37:49 EDT
See bug 98595. The pkg-config in FC2 looks in /usr/share/pkgconfig as
well as in /usr/lib/pkgconfig. You must be using a selfcompiled
pkgconfig, that change is actually in pkgconfig-0.14.0-6
Comment 3 Nickolay V. Shmyrev 2004-06-16 15:46:57 EDT
I have pkgconfig-0.14.0-1 :)

Anyway, thanks.

Note You need to log in before you can comment on or make changes to this bug.