Bug 1261567 - denyhosts.py[757]: [Errno 2] No such file or directory: '/var/log/secure'
denyhosts.py[757]: [Errno 2] No such file or directory: '/var/log/secure'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: denyhosts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 13:17 EDT by Nicolas Mailhot
Modified: 2015-09-09 15:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 13:39:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2015-09-09 13:17:41 EDT
systemctl status denyhosts
● denyhosts.service - SSH log watcher
   Loaded: loaded (/usr/lib/systemd/system/denyhosts.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since mar. 2015-09-08 21:53:44 CEST; 21h ago
 Main PID: 757 (code=exited, status=1/FAILURE)

sept. 08 21:53:44 arekh.localdomain systemd[1]: Started SSH log watcher.
sept. 08 21:53:44 arekh.localdomain denyhosts.py[757]: Can't read: /var/log/secure
sept. 08 21:53:44 arekh.localdomain denyhosts.py[757]: [Errno 2] No such file or directory: '/var/log/secure'
sept. 08 21:53:44 arekh.localdomain denyhosts.py[757]: Error deleting DenyHosts lock file: /var/lock/subsys/denyhosts
sept. 08 21:53:44 arekh.localdomain denyhosts.py[757]: [Errno 2] No such file or directory: '/var/lock/subsys/denyhosts'
sept. 08 21:53:44 arekh.localdomain systemd[1]: denyhosts.service: Main process exited, code=exited, status=1/FAILURE
sept. 08 21:53:44 arekh.localdomain systemd[1]: denyhosts.service: Unit entered failed state.
sept. 08 21:53:44 arekh.localdomain systemd[1]: denyhosts.service: Failed with result 'exit-code'.

denyhosts-2.10-6.fc23.noarch
Comment 1 Jason Tibbitts 2015-09-09 13:39:55 EDT
Well, you don't have /var/log/secure.  Not sure what you would expect denyhosts to do in the case where it has no file to read.

You will need to install and configure a syslog daemon as indicated in the documentation (README.fedora).
Comment 2 Nicolas Mailhot 2015-09-09 14:10:13 EDT
I'd expect denyhosts to declare its deps now they are no longer part of the Fedora base set
Comment 3 Jason Tibbitts 2015-09-09 15:16:45 EDT
You might, except that it's not possible to know which syslog daemon you would want or how to set it up.  And it won't be enabled in any case so you'd still get the same error.  Better to have proper documentation (which is there) as it's not a zero-configuration system.

Future releases may read from the journal if I can figure out how to make things work in a stable fashion.

Note You need to log in before you can comment on or make changes to this bug.