Bug 1261615 - Installation of H/A Swift Proxy fails to complete
Installation of H/A Swift Proxy fails to complete
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Jason Guiditta
Shai Revivo
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 15:08 EDT by Michael Solberg
Modified: 2016-07-18 16:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-18 16:02:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Solberg 2015-09-09 15:08:06 EDT
Description of problem:
Installation of the Swift proxy service on the H/A controller class used by the Foreman installer hangs when Swift is enabled.

Version-Release number of selected component (if applicable):
openstack-puppet-modules-2015.1.8-8.el7ost.noarch
master branch of quickstack from https://github.com/redhat-openstack/astapor

How reproducible:
100%

Steps to Reproduce:
1. Create a Controller host group which contains the following classes:
  quickstack::ntp
  quickstack::openstack_common
  quickstack::pacemaker::ceilometer
  quickstack::pacemaker::cinder
  quickstack::pacemaker::common
  quickstack::pacemaker::galera
  quickstack::pacemaker::glance
  quickstack::pacemaker::heat
  quickstack::pacemaker::horizon
  quickstack::pacemaker::keystone
  quickstack::pacemaker::load_balancer
  quickstack::pacemaker::memcached
  quickstack::pacemaker::neutron
  quickstack::pacemaker::nosql
  quickstack::pacemaker::nova
  quickstack::pacemaker::params
  quickstack::pacemaker::qpid
  quickstack::pacemaker::rabbitmq
  quickstack::pacemaker::swift

2. Set "include_swift" to True in quickstack::pacemaker::params

3. Apply host group to systems.

Actual results:

Puppet runs eventually time out waiting for "/tmp/ha-all-in-one-util.bash all_members_include swift".

Expected results:

Swift Proxy services should be installed on the controller.

Additional info:

This appears to be due to a change introduced here:

https://github.com/redhat-openstack/astapor/commit/a18b25d028c766c5df3675e7aea89e3f5603eaeb

"pcs-swift-server-set-up-on-this-node" should be running:
/tmp/ha-all-in-one-util.bash update_my_node_property swift

and it was changed to:
/tmp/ha-all-in-one-util.bash set_property swift running
Comment 3 Michael Solberg 2015-09-09 15:14:56 EDT
https://github.com/redhat-openstack/astapor/pull/563 resolves the issue for me.
Comment 4 Mike Burns 2015-09-09 15:29:44 EDT
what are you attempting to do?  OFI is not supported in OSP7 and only with staypuft (which does not support swift) in OSP6?
Comment 5 Michael Solberg 2015-09-17 09:44:25 EDT
I'm just cleaning up some of the puppet code in Quickstack and I wanted to tie my pull requests to bugs in bugzilla.  Is there a better place to file these issues?

Thanks.

Michael.
Comment 7 Jason Guiditta 2016-07-12 10:02:53 EDT
Same comment here as your other swift-related BZ.  I am happy to include in a build if needed and we can get acks, otherwise, lets close it if no longer needed.
Comment 8 Michael Solberg 2016-07-18 16:02:30 EDT
No need for an OFI build - I'd appreciate having the patches merged to master though. I'll close as upstream (understanding what that means for this).

Michael.

Note You need to log in before you can comment on or make changes to this bug.