Bug 126162 - firewire I/O error...
firewire I/O error...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 17:31 EDT by Kyle Pablo
Modified: 2015-01-04 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-05 16:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of firewire device errors (20.71 KB, text/plain)
2004-11-05 15:42 EST, Kyle Pablo
no flags Details

  None (edit)
Description Kyle Pablo 2004-06-16 17:31:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
On the latest kernel updates 1.435 and 1.427 I have been getting these
error messages in dmesg when using my firewire hdd:

ieee1394: Node changed: 0-01:1023 -> 0-00:1023
ieee1394: Node suspended: ID:BUS[0-00:1023]  GUID[0001a33000002163]
scsi0 (0:0): rejecting I/O to device being removed
scsi0 (0:0): rejecting I/O to device being removed
Buffer I/O error on device sda1, logical block 3326
lost page write due to I/O error on sda1
Aborting journal on device sda1.
journal commit I/O error
scsi0 (0:0): rejecting I/O to device being removed
Buffer I/O error on device sda1, logical block 14680135
lost page write due to I/O error on sda1
ext3_abort called.
EXT3-fs abort (device sda1): ext3_journal_start: Detected aborted journal
Remounting filesystem read-only
scsi0 (0:0): rejecting I/O to dead device
Buffer I/O error on device sda1, logical block 527
lost page write due to I/O error on sda1

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435

How reproducible:
Always

Steps to Reproduce:
1.Mount firewire hdd
2.play a file/mp3 off of it
3.firewire goes into read-only mode
    

Additional info:
Comment 1 Kyle Pablo 2004-09-14 15:13:58 EDT
I'm getting new errors for kernel-2.6.8-1.521:

scsi2 : SCSI emulation for IEEE-1394 SBP-2 Devices
ieee1394: sbp2: Error logging into SBP-2 device - login timed-out
sbp2: probe of 0001a33000002163-0 failed with error -16
ieee1394: Node changed: 0-01:1023 -> 0-00:1023
ieee1394: Node suspended: ID:BUS[0-00:1023]  GUID[0001a33000002163]
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
Aborting journal on device sda1.
scsi0 (0:0): rejecting I/O to dead device
Buffer I/O error on device sda1, logical block 527
lost page write due to I/O error on sda1
scsi0 (0:0): rejecting I/O to dead device
Buffer I/O error on device sda1, logical block 0
lost page write due to I/O error on sda1
ext3_abort called.
EXT3-fs abort (device sda1): ext3_journal_start: Detected aborted journal
Remounting filesystem read-only
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory #2
offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
ohci1394: fw-host0: SelfID received, but NodeID invalid (probably new
bus reset occurred): 0000FFC0
ieee1394: Node resumed: ID:BUS[0-00:1023]  GUID[0001a33000002163]
ieee1394: Node changed: 0-00:1023 -> 0-01:1023
scsi3 : SCSI emulation for IEEE-1394 SBP-2 Devices
ieee1394: sbp2: Logged into SBP-2 device
ieee1394: Node 0-00:1023: Max speed [S400] - Max payload [2048]
  Vendor: WDC WD12  Model: 00BB-00CJA1       Rev: 0.01
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sdb: 234441648 512-byte hdwr sectors (120034 MB)
SCSI device sdb: drive cache: write through
 sdb: sdb1
Attached scsi disk sdb at scsi3, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi3, channel 0, id 0, lun 0,  type 0
ieee1394: Node changed: 0-01:1023 -> 0-00:1023
ieee1394: Node suspended: ID:BUS[0-00:1023]  GUID[0001a33000002163]
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory #2
offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_readdir: directory #2 contains a
hole at offset 0

Comment 2 Kyle Pablo 2004-11-04 19:52:23 EST
scsi0 (0:0): rejecting I/O to dead device
scsi0 (0:0): rejecting I/O to dead device
scsi0 (0:0): rejecting I/O to dead device
scsi0 (0:0): rejecting I/O to dead device
journal_bmap: journal block not found at offset 451 on sda1
Aborting journal on device sda1.
scsi0 (0:0): rejecting I/O to dead device
Buffer I/O error on device sda1, logical block 527
lost page write due to I/O error on sda1
ext3_abort called.
EXT3-fs abort (device sda1): ext3_journal_start: Detected aborted journal
Remounting filesystem read-only
scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0

scsi0 (0:0): rejecting I/O to dead device
EXT3-fs error (device sda1): ext3_find_entry: reading directory
#8880345 offset 0
Comment 3 Kyle Pablo 2004-11-05 15:42:46 EST
Created attachment 106239 [details]
dmesg of firewire device errors

ok, i discovered that the root node keeps changing...it goes from /dev/sda1 ->
/dev/sdb1 -> /dev/sdc1 -> /dev/sdb1...i dont understand why its does this?
Comment 4 Kyle Pablo 2004-11-14 03:59:28 EST
upgraded to fc3 today...getting same errors...really starting to annoy
me...i need to figure out the problem...

Note You need to log in before you can comment on or make changes to this bug.