Bug 126163 - Please add option to download using wget or curl
Please add option to download using wget or curl
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 18:05 EDT by Robin Green
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 18:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2004-06-16 18:05:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040608

Description of problem:
For some reason, yum keeps failing to download headers from certain
repos, with this error:

retrygrab() failed for:
  http://hipnosi.net/yum/hipnosi/headers/hatools-0-0.99.09-1hip.i386.hdr
  Executing failover method
failover: out of servers to try
Error getting file
http://hipnosi.net/yum/hipnosi/headers/hatools-0-0.99.09-1hip.i386.hdr
[Errno 7] HTTP Error (CannotSendRequest):

But then I try to d/l the same URL again using wget, and it always
works fine. So couldn't you add a configuration option to use an
external downloader (e.g. wget or curl)? You could just allow a line
for an arbitrary shell command in the config file - that would be most
flexible.
Comment 1 Seth Vidal 2004-06-16 18:14:02 EDT
No. That's a mess and does not bear out well for using it as a library.
Comment 2 Uwe Menges 2004-07-15 05:05:54 EDT
So could you then please use wget's download code (copy & paste if it
must be) at least as additional download method, if not as *the*
download method?

Fact is that yum is not able to download something where wget has no
problems at all.

I suffer from the same problems behind our corporate Inktomi proxy
(probably broken, gpg needs undocumented(!) option "broken-http-proxy"
to get keys), updating with yum is a pita here because almost at every
package yum fails. When I fetch the failed package url with wget, yum
can afterwards get the url, too.

Using up2date -u works well.

The error shows up as follows (-d 10): 

localhdrpath=
/var/cache/yum/updates-released/headers/xorg-x11-ISO8859-9-75dpi-fonts-0-6.7.0-5.i386.hdr
for xorg-x11-ISO8859-9-75dpi-fonts i386
getting
/var/cache/yum/updates-released/headers/xorg-x11-ISO8859-9-75dpi-fonts-0-6.7.0-5.i386.hdr
failover: baseURL =
http://ftp-stud.fht-esslingen.de/pub/Mirrors/fedora.redhat.com/linux/core/updates/2/i386/
failover: path =
/headers/xorg-x11-ISO8859-9-75dpi-fonts-0-6.7.0-5.i386.hdr
retrygrab() failed for:
 
http://ftp-stud.fht-esslingen.de/pub/Mirrors/fedora.redhat.com/linux/core/updates/2/i386//headers/xorg-x11-ISO8859-9-75dpi-fonts-0-6.7.0-5.i386.hdr
  Executing failover method
failover: out of servers to try
Error getting file
http://ftp-stud.fht-esslingen.de/pub/Mirrors/fedora.redhat.com/linux/core/updates/2/i386//headers/xorg-x11-ISO8859-9-75dpi-fonts-0-6.7.0-5.i386.hdr
[Errno 6] ERROR: Url Return no Content-Length  - something is wrong

Note You need to log in before you can comment on or make changes to this bug.