Bug 1261733 - CoCo infrastructure should provide a timeout for each command to prevent entities to be locked forever.
CoCo infrastructure should provide a timeout for each command to prevent enti...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Ravi Nori
Petr Matyáš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 01:20 EDT by Maor
Modified: 2016-03-11 02:21 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some commands executed by Command Coordinator may not finish and may run for ever. Consequence: The commands are running for ever. Fix: The commands should be marked as FAILED after a user configurable number of minutes. CoCoLifeInMinutes in VdcOptions table can be used to configure the time out for CoCo commands Result: The CoCo commands that are still running after CoCoLifeInMinutes will be marked as FAILED and failure logic is executed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 02:21:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
ylavi: planning_ack?
masayag: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46136 master MERGED engine : CoCo infrastructure should provide a timeout for each command Never
oVirt gerrit 47088 ovirt-engine-3.6 MERGED engine : CoCo infrastructure should provide a timeout for each command Never

  None (edit)
Description Maor 2015-09-10 01:20:00 EDT
Description of problem:
CoCo infrastructure should provide a timeout for each command to prevent entities to be locked forever.
The behavior should be a bit similar to how it is being dome with asyncTasks.

There should be a parameter in the base parameter command that should be initialized every time with the default timeout, so the user will also be able to override it for specific operations.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Failed delete operations might make the client (CoCo) poll every time to check if the entity still exists 
2.
3.

Actual results:
The entity will be locked forever, since the delete will never happen

Expected results:
We should have a time out (or number of tries) that when this limit reached the entity will leave the lock state and present a failure event log

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-20 10:00:11 EDT
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-20 10:00:11 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Yaniv Lavi 2015-10-29 08:33:34 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 4 Petr Matyáš 2016-02-23 12:11:21 EST
Verified on 3.6.3-3

Note You need to log in before you can comment on or make changes to this bug.