Bug 1261787 - [Docs] [Admin] Describe iSCSI/FC storage domain removal in more detail
[Docs] [Admin] Describe iSCSI/FC storage domain removal in more detail
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.1
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.1
: 3.6.1
Assigned To: rhev-docs@redhat.com
https://access.redhat.com/documentati...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 03:26 EDT by Evgheni Dereveanchin
Modified: 2015-11-18 08:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 08:17:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgheni Dereveanchin 2015-09-10 03:26:36 EDT
Description of problem:
Currently the chapter 8.8.5 of the RHEV Administration Guide says that it's enough to remove a storage domain from RHEV Administrator Portal to get rid of it. However, due to bz#880738 and bz#1134144 it is required to remove paths from hosts manually before unzoning the LUNs on storage side. Failure to do so causes major stability issues in the environment. This affects all versions from 3.0 through 3.5 so I request adding a warning/note/link to KB on how to do this to avoid issues of RHEV.

Version-Release number of selected component (if applicable):
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Administration_Guide/sect-Storage_Tasks.html#idp33428112

How reproducible:
Always

Steps to Reproduce:
1. environment with several FC storage domains
2. go by the current doc to remove a storage domain
3. after completing the steps, unzone the LUN immediately

Actual results:
All datacenters unstable, SPM role flipping between hosts, VM migration storms caused by timeouts during LVM commands

Expected results:
Users are warned not to unzone LUNs before they're detached from hosts


Additional info:
https://access.redhat.com/solutions/129983

Note You need to log in before you can comment on or make changes to this bug.