Bug 1261821 - [RFE] Packages upgrade path checks in Delorean CI
[RFE] Packages upgrade path checks in Delorean CI
Status: CLOSED EOL
Product: RDO
Classification: Community
Component: distribution (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: hguemar
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 05:08 EDT by hguemar
Modified: 2016-05-19 11:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-19 11:49:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hguemar 2015-09-10 05:08:50 EDT
Description of problem:
Needs to add upgrade path testing for packages in Delorean CI

Actual results:
Packages upgrade path are not tested today, resulting in
broken upgrade path when package are incorrectly renamed.

Expected results:
Packagers should have feedback that their patchset break
the upgrade path so that broken patchsets are not approved
by mistake.


Additional info:
Some test case:
1. Install previous package in mock chroot then try updating it with new one.
2. Try installing some packages that requires the package and check that it picks the new one.
Comment 1 hguemar 2015-09-10 05:10:06 EDT
Not sure to whom assign it, so I temporarily assigned it to me but I could help implementing this.
Comment 4 Chandan Kumar 2016-05-19 11:49:38 EDT
This bug is against a Version which has reached End of Life.
If it's still present in supported release (http://releases.openstack.org), please update Version and reopen.

Note You need to log in before you can comment on or make changes to this bug.