Bug 1261851 - Cluster cpu type can't be edited
Cluster cpu type can't be edited
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
---
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: jniederm
Ilanit Stein
: FutureFeature, Reopened
: 1288116 1288122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 06:16 EDT by jniederm
Modified: 2016-02-18 06:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: (rather bug-fix) Setting 'CPU type' in freshly created cluster causes NPE. It was fixed without other functionality changes. Reason: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:17:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.z?
rule-engine: planning_ack?
ofrenkel: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
stack-trace.txt (15.24 KB, text/plain)
2015-09-10 06:16 EDT, jniederm
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45988 master MERGED core: Fix of NPE in UnsupportedVmCpuClusterEditChecker Never
oVirt gerrit 46001 ovirt-engine-3.6 MERGED core: Fix of NPE in UnsupportedVmCpuClusterEditChecker Never
oVirt gerrit 48171 None None None Never
oVirt gerrit 50017 ovirt-engine-3.6 MERGED engine: Fix NPE in edit cluster Never

  None (edit)
Description jniederm 2015-09-10 06:16:45 EDT
Created attachment 1072079 [details]
stack-trace.txt

Description of problem:
... probably only if none cpu type is currently set (fresh cpu installation).

Version-Release number of selected component (if applicable):
4.0 master, commit 26ae556

How reproducible:
100%

Steps to Reproduce:
1. Clear engine installation without hosts
2. Open "Default" cluster edit dialog
3. Set CPU type
4. click ok

Actual results:
stacktrace in engine log, cpu type not saved

Expected results:
cpu type saved without errors
Comment 1 Ilanit Stein 2015-11-05 09:50:15 EST
Verified on rhevm 3.6.0-18

cpu type updated with no problem.

No stacktrace on engine.log:

[20195bd9] Running command: UpdateVdsGroupCommand internal: false. Entities affected :  ID: 00000002-0002-0002-0002-00000000006a Type: VdsGroupsAction group EDIT_CLUSTER_CONFIGURATION with role type ADMIN
2015-11-05 14:47:30,585 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-7) [20195bd9] Correlation ID: 20195bd9, Call Stack: null, Custom Event ID: -1, Message: Host cluster Default was updated by admin@internal
Comment 2 Sandro Bonazzola 2015-11-27 02:54:18 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.
Comment 3 Piotr Kliczewski 2015-12-04 09:09:59 EST
The issue still exists on master and 3.6.
Comment 4 Red Hat Bugzilla Rules Engine 2015-12-04 09:10:01 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Piotr Kliczewski 2015-12-04 09:13:21 EST
*** Bug 1288122 has been marked as a duplicate of this bug. ***
Comment 6 Michal Skrivanek 2015-12-04 10:57:08 EST
The new occurence also happens because there was no CPU type set - a brand new Cluster without any host
Comment 7 Red Hat Bugzilla Rules Engine 2015-12-04 10:57:12 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 8 jniederm 2015-12-07 10:31:14 EST
Steps to Reproduce (for 1st re-open):
1. Clear engine installation without hosts
2. Open "Default" cluster edit dialog
3. Untick "Enable Virt Service"
4. Tick "Enable Gluster Service"
4. Click Ok
Comment 9 Oved Ourfali 2015-12-08 04:25:36 EST
*** Bug 1288116 has been marked as a duplicate of this bug. ***
Comment 10 Sandro Bonazzola 2015-12-22 06:02:52 EST
Can you please add some doc-text?
Comment 11 Sandro Bonazzola 2015-12-23 10:07:39 EST
This bug has target milestone 3.6.2 and is on modified without a target release.
This may be perfectly correct, but please check if the patch fixing this bug is included in ovirt-engine-3.6.2. If it's included, please set target-release to 3.6.2 and move to ON_QA. Thanks.
Comment 12 jniederm 2016-01-04 08:21:43 EST
Doc-text added. 
However attached patches are mere bug-fixes so I doubt it is somehow beneficial.
Comment 13 jniederm 2016-01-04 08:34:21 EST
Patches http://gerrit.ovirt.org/50017 and http://gerrit.ovirt.org/46001 are in virt-engine-3.6.2 tag.
Comment 14 Ilanit Stein 2016-01-20 06:30:07 EST
Verified on rhevm 3.6.2.5-0.1.el6.

Followed reproduce steps in comment #8.
and in addition set the cpu type to "Intel Conroe Family" 
No stacktrace was seen on engine.log

Note You need to log in before you can comment on or make changes to this bug.