Bug 1261859 - disable-legacy=on option cause guest can not read the boot disk
disable-legacy=on option cause guest can not read the boot disk
Status: CLOSED DUPLICATE of bug 1243364
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2015-09-10 06:30 EDT by Yiqian Wei
Modified: 2015-09-15 23:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-15 23:19:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
guest screen (11.10 KB, image/png)
2015-09-10 06:34 EDT, Yiqian Wei
no flags Details

  None (edit)
Description Yiqian Wei 2015-09-10 06:30:42 EDT
Description of problem:
Boot guest with virtio-blk-pci or virtio-scsi-pci and disable-legacy=on. guest can not read the boot disk. If set disable-legacy=off, then guest works well.

Version-Release number of selected component (if applicable):
host kernel:3.10.0-314.el7.x86_64
qemu version: qemu-kvm-rhev-2.3.0-22.el7.x86_64
seabios :seabios-1.7.5-11.el7.x86_64

How reproducible:

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M pc-i440fx-rhel7.2.0 -cpu SandyBridge \
-enable-kvm -m 2G -smp 4 -name rhel7.2 \

-rtc base=localtime,clock=host,driftfix=slew -uuid 6afa5f93-2d4f-420f-81c6-e5fdddbd1c83 -spice disable-ticketing,port=5931 -monitor stdio \

-drive file=/home/rhel7.2-new.qcow2,if=none,id=drive-scsi-disk,format=qcow2,cache=none,werror=stop,rerror=stop  -device virtio-blk-pci,disable-legacy=off,drive=drive-scsi-disk \

-vnc :11


Actual results:
guest boot fail. can not read boot disk

Expected results:

Additional info:
Comment 1 Yiqian Wei 2015-09-10 06:34:19 EDT
Created attachment 1072082 [details]
guest screen
Comment 4 jason wang 2015-09-15 23:19:16 EDT
Looks a duplicated to me.

*** This bug has been marked as a duplicate of bug 1243364 ***

Note You need to log in before you can comment on or make changes to this bug.