Bug 126206 - arts error on startup
arts error on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: arts (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 11:26 EDT by Mattia Verga
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 09:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattia Verga 2004-06-17 11:26:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.6) Gecko/20040510

Description of problem:
Every time I boot up the Pc and I log in, arts give me the error:

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such device)
The sound server will continue, using the null output device.

If I restart the sound server or if I log out and then log in for the
second time everything works fine.

Version-Release number of selected component (if applicable):
1.2.2-2

How reproducible:
Always

Steps to Reproduce:
1. Boot up the Pc
2. Log in into kde
3. Arts give the error
4. log out and then log in and everything works
    

Expected Results:  arts should work at the first log in

Additional info:

My sound chipset is integrated in the via kt400 chipset of the
motherboard (Asus a7v8x)
Comment 1 Andrea Santilli 2004-07-02 07:24:49 EDT
Here I got the same error. I've got an Asus P4P8x but it doesnt seem a
motherboard-related bug. It's like the alsa modules can't be loaded
before arts. If I restart arts it's alright
I get this error:

device /dev/dsp can't be opened (No Such Device)
Comment 2 Mattia Verga 2004-07-03 10:02:44 EDT
I'm not sure if this is a correct action, but if I kill arts and then
relaunch it, alsa give some errors:

[root@mattia root]# kill 2630
[root@mattia root]# artsd
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
Comment 3 Andrea Santilli 2004-07-03 15:27:09 EDT
mmmmm
I use arts in realtime priority. So kde doesn't run artsd but
artswrapper...

However yes, if I run artsd I get:
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
...but arts is running and working.

If I run artswrapper I get:
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
Can't set real-time scheduling priority.
You need to run artswrapper as root or
setuid root. This means that you will
likely not be able to produce acceptable
sound (i.e. without clicks and breaks).
...and arts is still works.

Comment 4 Mattia Verga 2004-07-11 06:03:05 EDT
Hey...
I tried to install kde 3.2.3-0.1: the error is still there....

I tried to disable the kde startup sound: it works!!!!
Comment 5 Mattia Verga 2004-07-12 11:48:46 EDT
I've talked too early...
after a couple of times it started without errors now it doesn't work
anymore (no changes I made from the last time it worked).
Now if I kill and restart arts it give me the common error plus
something more:

ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
unix_connect: can't connect to server
(unix:/tmp/mcop-root/mattia_fedora_it-0a57-40f2b12f)
Comment 6 Albert Tumanov 2005-01-10 13:26:13 EST
Similar problem here.
After KDE starts, the aforementioned message occurs.
If I try to start arts manually, I get:

# artsd
unix_connect: can't connect to server
(unix:/tmp/mcop-root/localhost_localdomain-0a41-41e2c7f4)
ALSA lib pcm_hw.c:1056:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p
failed: No such device
Error while initializing the sound driver:
device: default can't be opened for playback (No such device)
Comment 7 Friedrich Gonzalez 2005-02-11 01:26:56 EST
Every time i booted I got the issue.
i have a intel 865glc with internal sound card.
Linux cyber02.no-ip.org 2.6.10-1.12_FC2 #1 Wed Feb 2 01:13:49 EST 2005
i686 i686 i386 GNU/Linux
kdebase-3.2.2-8.FC2
arts-1.2.2-2

However i find a way to solve it:
init 1
rm -rf /tmp/*
reboot

Now artsd doesnt show any error at startup. i thought this may help
some of you.
Comment 8 Ngo Than 2005-02-11 09:15:55 EST
the problem is that pam does not set the correct permission devices for
sound e.g /dev/dsp* /dev/audio* /dev/mixer* .. after user has logged in.

it's a bug in pam and seems to be fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.