Bug 126208 - gnome-panel-screenshot is not working properly with the main menu opened
gnome-panel-screenshot is not working properly with the main menu opened
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-panel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: MoveUpstream
: 125775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 11:58 EDT by Frederic
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 06:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frederic 2004-06-17 11:58:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Bad: Indeed, the screenshot does not work correctly when the main 
menu (red hat on the left and at the bottom of the Desktop) is open.

Good: When the main menu is not open the screen shot work correctly.

Version-Release number of selected component (if applicable):
gnome-panel-2.2.2.1-4

How reproducible:
Always

Steps to Reproduce:
1. Open a gnome session under any kinf of user.
2.click on the main menu (red hat on the left and at the bottom of 
the Desktop )
3.Press the shortcut "Print Screen" which should launch the gnome-
panel-screenshot application.

Actual Results:  Nothing happens. In any case the gnome-panel-
screenshot application does appear.
    

Expected Results:  The gnome-panel-screenshot application should be 
launched.

Additional info:
Comment 1 Mark McLoughlin 2004-06-18 07:21:22 EDT
This is unfortunate, but expected. Basically, the main menu grabs the
keyboard when it pops up preventing the window manager from seeing the
printscreen keypress. The main menu needs to grab the keyboard so that
you can navigate the menus with the keyboard.

To take a screenshot like this you'll need to launch
gnome-panel-screenshot with a timer. E.g. go to "Run Application" and
enter "gnome-panel-screenshot --delay 5", hit return, open the main
menu and after 5 seconds the screenshot will be taken.

We may be able to make the main menu itself see the printscreen key
press and take a screenshot, but this wouldn't work for all menus
(e.g. the menus in an application). If we make this enhancement, we'll
do it in upstream GNOME, however.
Comment 2 Mark McLoughlin 2004-06-24 06:54:15 EDT
Okay, lets track this upstream now:

http://bugzilla.gnome.org/show_bug.cgi?id=144907
Comment 3 Mark McLoughlin 2004-07-19 10:46:51 EDT
*** Bug 125775 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.