Bug 1262091 - FTBFS: libint fails to build on aarch64
FTBFS: libint fails to build on aarch64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARM64/F-ExcludeArch-aarch64
  Show dependency treegraph
 
Reported: 2015-09-10 15:24 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2015-10-04 15:14 EDT (History)
5 users (show)

See Also:
Fixed In Version: binutils-2.25-15.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 15:14:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for binutils 2.25-14 failure (356 bytes, patch)
2015-09-30 07:16 EDT, Marcin Juszkiewicz
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 18668 None None None Never

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2015-09-10 15:24:59 EDT
Description of problem:
When building libint on aarch64, the following linking error occurs at final link stage:
[...]
.libs/hrr1_build_gh.o: In function `hrr1_build_gh(double const*, double*, double*, double*, int)':
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_gh.cc:11:(.text+0x4c88): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_gh_0(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_gh.o
/builddir/build/BUILD/libint-0e0ffa7887e74e6ab1fb07c89be55f776c733731/src/lib/libint/src/hrr1_build_gh.cc:12:(.text+0x4ca0): relocation truncated to fit: R_AARCH64_CALL26 against symbol `_hrr1_build_gh_1(double const*, double*, double*, double*, int)' defined in .text section in .libs/hrr1_build_gh.o

Version-Release number of selected component (if applicable):
1.1.6-6.fc23

How reproducible:
Always.

Steps to Reproduce:
1. arm-koji build rawhide git://pkgs.fedoraproject.org/libint?#119a604475eaa95f2cfcfd8e2fb4132c7e989003

Additional information:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3176102
Comment 1 Susi Lehtola 2015-09-10 19:19:34 EDT
gcc bug?
Comment 2 Dominik 'Rathann' Mierzejewski 2015-09-11 03:51:00 EDT
Looks like linker bug: https://sourceware.org/bugzilla/show_bug.cgi?id=18668
Comment 3 Dominik 'Rathann' Mierzejewski 2015-09-11 03:52:49 EDT
Bug in binutils (2.25.1-4.fc24). Looks like it's fixed upstream already, so please backport.
Comment 4 Dominik 'Rathann' Mierzejewski 2015-09-11 03:53:48 EDT
This is blocking the aarch64 build of cp2k and other stuff that depends on libint.
Comment 5 Nick Clifton 2015-09-11 14:01:01 EDT
Hi Dominik,

  Please try out binutils-2.25.1-6.fc24

Cheers
  Nick
Comment 6 Dominik 'Rathann' Mierzejewski 2015-09-12 16:32:49 EDT
libint-1.1.6-6.fc24 built successfully, thanks Nick!

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3177887
Comment 7 Peter Robinson 2015-09-14 06:19:01 EDT
(In reply to Nick Clifton from comment #5)
> Hi Dominik,
> 
>   Please try out binutils-2.25.1-6.fc24

Can we get this fix in F-23 too please?
Comment 8 Nick Clifton 2015-09-14 06:49:00 EDT
Hi Peter,

> Can we get this fix in F-23 too please?

I think that Fedora 23 is frozen at the moment...

Cheers
  Nick
Comment 9 Peter Robinson 2015-09-14 07:02:23 EDT
(In reply to Nick Clifton from comment #8)
> Hi Peter,
> 
> > Can we get this fix in F-23 too please?
> 
> I think that Fedora 23 is frozen at the moment...

Updates can still be submitted and they go to f23-updatest-testing as per a standard cycle. They're held there until Beta gets signed off and which point they continue on their way post beta.
Comment 10 Nick Clifton 2015-09-14 08:28:07 EDT
OK then, please await the arrival of:

  binutils-2.25-14.fc23

Cheers
  Nick
Comment 11 Peter Robinson 2015-09-24 03:00:15 EDT
>   binutils-2.25-14.fc23

Can this please be submitted as an update to F-23 please?
Comment 12 Fedora Update System 2015-09-27 05:21:49 EDT
binutils-2.25-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3ed7d1146a
Comment 13 Fedora Update System 2015-09-29 02:22:33 EDT
binutils-2.25-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update binutils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3ed7d1146a
Comment 14 Peter Robinson 2015-09-30 00:39:41 EDT
Patch fails to apply:

+ echo 'Patch #17 (binutils-2.25.1-dynamic_list.patch):'
Patch #17 (binutils-2.25.1-dynamic_list.patch):
+ /usr/bin/patch -p1 -b --suffix .dynamic_list~ --fuzz=0
patching file gold/layout.cc
patching file gold/options.cc
patching file gold/symtab.h
patching file gold/testsuite/Makefile.am
patching file gold/testsuite/Makefile.in
Hunk #1 succeeded at 5266 (offset -11 lines).
+ echo 'Patch #18 (binutils-2.25-aarch64-pr18668.patch):'
Patch #18 (binutils-2.25-aarch64-pr18668.patch):
+ /usr/bin/patch -p1 --fuzz=0
patching file bfd/elfnn-aarch64.c
Hunk #2 FAILED at 4394.
1 out of 2 hunks FAILED -- saving rejects to file bfd/elfnn-aarch64.c.rej
Comment 15 Marcin Juszkiewicz 2015-09-30 07:16 EDT
Created attachment 1078594 [details]
fix for binutils 2.25-14 failure
Comment 16 Nick Clifton 2015-09-30 07:53:01 EDT
Hi Guys,

This is very strange - I cannot reproduce this failure.  In fact applying Marcin's patch actually breaks the build for me.  Peter - does Marcin's patch work for you ?  If so then there must be something wrong with my build system, although I have no idea what.

Cheers
  Nick
Comment 17 Marcin Juszkiewicz 2015-09-30 09:12:57 EDT
Nick: f24 is fine as it is, f23 fails without that patch.
Comment 18 Nick Clifton 2015-09-30 09:34:40 EDT
(In reply to Marcin Juszkiewicz from comment #17)
> Nick: f24 is fine as it is, f23 fails without that patch.

If you say so - but I have tried several times using the F23 sources and they always work for me.

Cheers
  Nick
Comment 19 Marcin Juszkiewicz 2015-09-30 09:50:59 EDT
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=3208788 failed on applying: 

Patch #18 (binutils-2.25-aarch64-pr18668.patch):
+ /usr/bin/patch -p1 --fuzz=0
patching file bfd/elfnn-aarch64.c
Hunk #2 FAILED at 4394.
1 out of 2 hunks FAILED -- saving rejects to file bfd/elfnn-aarch64.c.rej
error: Bad exit status from /var/tmp/rpm-tmp.Bltrvp (%prep)
Comment 20 Nick Clifton 2015-09-30 10:48:02 EDT
Ah - found it - the problem only occurs with an aarch64 native or cross build.  If building for any other target a previous patch is not applied (patch16) and this meant that patch18 did apply.

I have now checked in a fix to always apply patch16, even if the target is not aarch64.  (The patch only affects aarch64 files, so this should not be a problem).  Then I updated patch18 with Marcin's fix, so that now the F23 binutils should build for all targets.  This fix is in:

  binutils-2.25-15.fc23

Cheers
  Nick
Comment 21 Fedora Update System 2015-09-30 22:45:33 EDT
binutils-2.25-15.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-34e344e965
Comment 22 Fedora Update System 2015-10-03 21:53:39 EDT
binutils-2.25-15.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update binutils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-34e344e965
Comment 23 Fedora Update System 2015-10-04 15:14:52 EDT
binutils-2.25-15.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.