Bug 126218 - s390 kernels do not export _sb_findmap
s390 kernels do not export _sb_findmap
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 13:25 EDT by Manish Singh
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:55:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Candidate #1 (1.17 KB, patch)
2004-09-01 19:01 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Manish Singh 2004-06-17 13:25:02 EDT
Description of problem:
find_first_bit and find_next_bit need the _sb_findmap table, but
that's not exported (in 2.4.21-15.EL and prior at least), so they
can't be used from modules. Fix is to
EXPORT_SYMBOL_NOVERS(_sb_findmap); in s390_ksyms.c, for both the s390
and s390x arches. This is already in 2.6 upstream, and accordingly it
looks like RHEL4 doesn't have this problem.

Version-Release number of selected component (if applicable):
2.4.21-15.EL

How reproducible:
Try to compile and load a module that uses find_first_bit or
find_next_bit (e.g., ocfs2)
Comment 1 Pete Zaitcev 2004-09-01 19:01:09 EDT
Created attachment 103379 [details]
Candidate #1
Comment 2 Ernie Petrides 2004-09-18 01:59:29 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.7.EL).
Comment 3 John Flanagan 2004-12-20 15:55:21 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.