Bug 1262187 - Image openshift/origin-gitserver is 4 months ago need update in dockerhub
Image openshift/origin-gitserver is 4 months ago need update in dockerhub
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Image (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Cesar Wong
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 01:40 EDT by DeShuai Ma
Modified: 2016-05-12 13:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:11:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DeShuai Ma 2015-09-11 01:40:05 EDT
Description of problem:
The image openshift/origin-gitserver it too old in dockerhub, when run gitserver example on ose env, it always failed, because the image is too old, it's 4 months ago. On our origin ec2 env, the image is local build and latest, no this issue. When import the latest image from ec2 to ose env, it can also works well. So we should update the image in dockerhub.

Version-Release number of selected component (if applicable):
docker hub openshift/origin-gitserver id: 834284fa842b 

How reproducible:
Always

Steps to Reproduce:
1.Create private gitserver in ose env.
$ oc create -f https://raw.githubusercontent.com/openshift/origin/master/examples/gitserver/gitserver.yaml

2.Check the gitserver pod
dhcp-128-95:gitserver dma$ oc get pod
NAME                 READY     STATUS    RESTARTS   AGE
gitserver-1-deploy   1/1       Running   0          2m
gitserver-1-qyq8s    0/1       Running   5          2m

Actual results:
2.Should deploy gitserver success and the pod is running and no error.

Expected results:
2.Can't deploy gitserver successfully

Additional info:
docker.io/openshift/origin-gitserver               latest              834284fa842b        4 months ago        526.7 MB
pod describe log: http://fpaste.org/265954/19475291/
pod container log: http://fpaste.org/265955/41947624/
Comment 1 Cesar Wong 2015-11-13 11:19:59 EST
PR https://github.com/openshift/origin/pull/5891
Comment 2 DeShuai Ma 2015-11-19 21:02:23 EST
[fedora@ip-172-18-9-199 ~]$ openshift version
openshift v1.1-60-g0411059
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

[fedora@ip-172-18-9-199 ~]$ docker images|grep origin-gitserver
docker.io/openshift/origin-gitserver     latest              d0db37dd3979        12 hours ago        482.9 MB

Note You need to log in before you can comment on or make changes to this bug.