Bug 1262331 - ID Ranges of trusted AD domains/subdomains are not deleted from UI when trust is removed.
ID Ranges of trusted AD domains/subdomains are not deleted from UI when trust...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 08:30 EDT by Sudhir Menon
Modified: 2015-09-15 02:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 02:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IDRanges Tab displaying AD/subdomains ranges (104.32 KB, image/png)
2015-09-11 08:30 EDT, Sudhir Menon
no flags Details

  None (edit)
Description Sudhir Menon 2015-09-11 08:30:59 EDT
Created attachment 1072547 [details]
IDRanges Tab displaying AD/subdomains ranges

Description of problem: ID Ranges of trusted AD domains/subdomains are not deleted from UI when trust is removed.


Version-Release number of selected component (if applicable):


How reproducible:Always


Steps to Reproduce:
1. Login to IPA-Server. Ensure that trust is established with AD.
2. Delete the trust established and ensure trust is deleted.
[smenon@ipa01 ~]$ sudo ipa trust-del
Realm name: TEST.IN
-----------------------
Deleted trust "TEST.IN"
-----------------------

3. Now login to UI. Navigate to IPA Server Tab ID Ranges

Actual results:
ID ranges of the trusted AD and child domain are listed in the UI.


Expected results:
ID ranges of the trusted AD and child domains should be removed since the trust is deleted and the domains are not listed in the Trusts Tab in the UI.


Additional info:
Comment 4 Tomas Babej 2015-09-15 02:54:13 EDT
ID ranges are not subject to automated removal after the trust is deleted. A manual intervention step is necessary from the admin, confirming he wants the ID range removed.

Note You need to log in before you can comment on or make changes to this bug.