Bug 1262389 - Build Networking Differed from SDN causing Proxy Configurations not to work.
Build Networking Differed from SDN causing Proxy Configurations not to work.
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Eric Paris
Meng Bo
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 10:06 EDT by Eric Rich
Modified: 2015-09-11 18:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 18:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1610413 None None None Never

  None (edit)
Description Eric Rich 2015-09-11 10:06:24 EDT
Description of problem:

Networking between build pods and imagestream pod are not the same. This causes issues with when OpenShift is behind a proxy as shown below: 

I0910 10:39:55.756609       1 sti.go:393] Downloading: https://repo1.maven.org/maven2/org/jboss/bom/jboss-javaee-6.0-with-tools/1.0.0.M1/jboss-javaee-6.0-with-tools-1.0.0.M1.pom
E0910 10:39:58.807202       1 sti.go:419] Sep 10, 2015 10:39:58 AM org.apache.http.impl.client.DefaultHttpClient tryConnect
E0910 10:39:58.807785       1 sti.go:419] INFO: I/O exception (java.net.NoRouteToHostException) caught when connecting to the target host: No route to host

Version-Release number of selected component (if applicable): 3.0.1

How reproducible: Very

Steps to Reproduce:

1. Establish a SQUID and block traffic except trough the proxy
2. install Basic 1 Broker, 2 Node OSE setup. 
3. Establish a build: using https://github.com/bit4man/kitchensink-html5-mobile-example (or similar kitchen sink build) 
   - Note: Changes to the following were made to enable proxy http://post-office.corp.redhat.com/archives/openshift-sme/2015-August/msg01004.html

Actual results:

Builds Fails: 

I0910 10:39:55.756609       1 sti.go:393] Downloading: https://repo1.maven.org/maven2/org/jboss/bom/jboss-javaee-6.0-with-tools/1.0.0.M1/jboss-javaee-6.0-with-tools-1.0.0.M1.pom
E0910 10:39:58.807202       1 sti.go:419] Sep 10, 2015 10:39:58 AM org.apache.http.impl.client.DefaultHttpClient tryConnect
E0910 10:39:58.807785       1 sti.go:419] INFO: I/O exception (java.net.NoRouteToHostException) caught when connecting to the target host: No route to host

Expected results:

STI is to complete the build of https://github.com/openshift/kitchensink-example
- Note: Changes to the following were made to enable proxy http://post-office.corp.redhat.com/archives/openshift-sme/2015-August/msg01004.html

Additional info:

# docker ps
CONTAINER ID        IMAGE                                                         COMMAND                CREATED             STATUS              PORTS                NAMES
496ddc7de255        registry.access.redhat.com/jboss-eap-6/eap-openshift:latest   "/bin/sh -c 'tar -C    7 minutes ago       Up 7 minutes        8080/tcp, 8443/tcp   elated_hopper                                                                                   
0c47e5aed093        openshift3/ose-sti-builder:v3.0.1.0                           "/usr/bin/openshift-   7 minutes ago       Up 7 minutes                             k8s_sti-build.1b8182a7_kitchensink-6-build_demo_44093bf0-588a-11e5-bdcd-525400efa961_57803a89   
60f113a6172a        openshift3/ose-pod:v3.0.1.0                                   "/pod"                 7 minutes ago       Up 7 minutes                             k8s_POD.892ec37e_kitchensink-6-build_demo_44093bf0-588a-11e5-bdcd-525400efa961_8da4fc48         

Doing docker exec on the LAST of the two build containers fails to use the proxy.
The docker exec on the FIRST of the build container succeeds.

[jboss@496ddc7de255 ~]$ curl -x http://192.168.100.5:3128 http://cnn.com
curl: (7) Failed connect to 192.168.100.5:3128; No route to host
[jboss@496ddc7de255 ~]$ exit

[root@node2 ~]# docker exec -it 0c47e5aed093 /bin/bash
[root@kitchensink-6-build openshift]# curl -x http://192.168.100.5:3128 http://cnn.com
<html>
<head><title>301 Moved Permanently</title></head>
<body bgcolor="white">
<center><h1>301 Moved Permanently</h1></center>
<hr><center>nginx</center>
</body>
</html>
Comment 3 Cesar Wong 2015-09-11 11:27:07 EDT
Sending to networking since the pod can't reach the proxy.
Comment 4 Ben Parees 2015-09-11 12:57:38 EDT
Can you include level 5 build logs so we can confirm the http proxy is being set?

but i don't think that's the issue since your docker exec shows the proxy is fundamentally unreachable from the build pod.
Comment 5 Brenton Leanhardt 2015-09-11 13:06:46 EDT
When I was on the call we definitely saw maven was trying to access the proxy.  It said something like "Fetching <some url> via <the proxy>:3128"
Comment 10 Eric Rich 2015-09-11 18:20:32 EDT
This seems to be an issue with moving systems and altering IP addresses.

Note You need to log in before you can comment on or make changes to this bug.