Bug 126243 - (xkb-croatian) keyboard configuration problem under X (underscore missing)
keyboard configuration problem under X (underscore missing)
Status: CLOSED DUPLICATE of bug 118409
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
: 126244 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-06-17 18:21 EDT by Hrvoje Dagelic
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:04:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hrvoje Dagelic 2004-06-17 18:21:08 EDT
Description of problem:

Impossible to get an underscore with Croatian, Serbian and Slovene
keyboard layout under X running Fedora core 2 (Tettnang). Instaead of
an underscore a question mark  is  printed. This does not occur at
virtual consoles.

Version-Release number of selected component (if applicable):


How reproducible, steps to reproduce:
  Edit /etc/X11/xorg.conf
  in the "keyboard" section change "XkbLayout" to this:
        Option      "XkbLayout" "hr"

  press right shift and the key just beside it (on the left)
  - you will get an "?" instead of an underscore
  - if you press shift and a second key on the left of backspace key
  you will also get an "?"
Comment 1 Marko Milicevic 2004-06-24 15:49:46 EDT
I also noticed that behaviour (with croatian keyboard settings). 
Never seen something like that before on any other Linux distro...
Hope that it will be fixed soon.
Comment 2 Mike A. Harris 2004-07-05 21:08:13 EDT
*** Bug 126244 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2004-07-05 23:51:09 EDT

*** This bug has been marked as a duplicate of 118409 ***
Comment 4 Ivo P. 2004-10-22 05:30:49 EDT
just add the following line 

key <AB10> { [ minus, underscore, dead_belowdot, dead_abovedot ] };

to the /etc/X11/xkb/symbols/pc/hr   file
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.