Bug 1262460 - Backport mon: add a cache layer over MonitorDBStore #5524
Backport mon: add a cache layer over MonitorDBStore #5524
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.2.3
x86_64 Linux
unspecified Severity high
: rc
: 1.2.4
Assigned To: Kefu Chai
ceph-qe-bugs
:
: 1262492 (view as bug list)
Depends On:
Blocks: 1319075 1228319
  Show dependency treegraph
 
Reported: 2015-09-11 15:08 EDT by Kyle Squizzato
Modified: 2017-07-30 11:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: ceph-0.80.8-17 (RHEL) and ceph v0.80.8.5 (Ubuntu & CentOS 6)
Doc Type: Bug Fix
Doc Text:
Prior to this update, poor LevelDB performance in Ceph's monitors could cause spurious elections. This could lead to slow requests during re-balancing. With this update, Ceph now caches the osdmap to be sent to the monitor clients, and cluster performance is improved.
Story Points: ---
Clone Of:
: 1262985 (view as bug list)
Environment:
Last Closed: 2015-10-01 16:25:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1590683 None None None 2017-07-30 11:08 EDT
Ceph Project Bug Tracker 12638 None None None Never
Red Hat Product Errata RHBA-2015:1857 normal SHIPPED_LIVE ceph bug fix update 2015-10-01 20:25:18 EDT

  None (edit)
Description Kyle Squizzato 2015-09-11 15:08:32 EDT
Help to prevent spurious election behavior caused by poor leveldb performance which leads to slow OSD restarts.

Upstream tracker: http://tracker.ceph.com/issues/12638 
Upstream PR: https://github.com/ceph/ceph/pull/5524
Comment 6 Ken Dreyer (Red Hat) 2015-09-15 17:53:34 EDT
Fix will be in non-RHEL Ceph v0.80.8.5
Comment 7 Tamil 2015-09-17 17:38:25 EDT
Kefu, can you please tell us the steps to verify the bug fix.
Comment 8 Kefu Chai 2015-09-17 22:33:39 EDT
Tamil, i am not sure if we have a way to verify the cache for the monstore. the cache layer speeds up the access to the leveldb. we don't leave traces/print extra message when we are accessing the leveldb directly without the cache, and no extra message is printed when we are using the cache.
Comment 14 errata-xmlrpc 2015-10-01 16:25:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1857
Comment 15 Ken Dreyer (Red Hat) 2015-10-21 12:07:47 EDT
*** Bug 1262492 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.