Bug 1262528 - mscore fails to start.
mscore fails to start.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mscore (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brendan Jones
Fedora Extras Quality Assurance
:
: 1278923 1279718 1280446 1283206 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-12 04:05 EDT by Rodd Clarkson
Modified: 2015-11-29 01:23 EST (History)
10 users (show)

See Also:
Fixed In Version: mscore-2.0.1-6.fc23 mscore-2.0.1-6.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-28 15:22:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2015-09-12 04:05:51 EDT
Description of problem:

I've installed mscore using the following command:

sudo dnf install mscore.

The installation worked fine with all dependancies installed, however mscore fails to start.

Launching from the icon seems to do nothing.

Running it from the command line has a similar result and ps ax shows no process running.

You can run mscore --help which shows the help including information about the program, so something seems to work.



Version-Release number of selected component (if applicable):

mscore-2.0.1-2.fc23.x86_64



How reproducible:

So far very.


Steps to Reproduce:
1.  Install mscore
2.  run mscore from the command line



Actual results:

Nothing happens



Expected results:

MuseScore (mscore) should start.



Additional info:

running mscore --help shows the following:

$ mscore --help
MuseScore: Music Score Editor; Version 2.0.1; Build b25f81d
Usage: mscore flags scorefile
   Flags:
   -v        print version
   -d        debug mode
   -L        layout debug
   -s        no internal synthesizer
   -m        no midi
   -a driver use audio driver: jack alsa pulse portaudio
   -n        start with new score
   -I        dump midi input
   -O        dump midi output
   -o file   export to 'file'; format depends on file extension
   -r dpi    set output resolution for image export
   -T margin trim exported image with specified margin (in pixels)
   -x factor set scaling factor for GUI elements
   -S style  load style file
   -p name   execute named plugin
   -P        save template mode, no page size
   -F        use factory settings
   -R        revert to default preferences
   -i        load icons from INSTALLPATH/icons
   -e        enable experimental features
   -c dir    override config/settings folder
   -t        set testMode flag for all files
   -M file   specify MIDI import operations file
   -w        no web view in start center
Comment 1 Rodd Clarkson 2015-09-12 04:06:50 EDT
I've tried moving .config/MuseScore in case this might have been conflicting as it was for an older version but there's no improvement.
Comment 2 Rodd Clarkson 2015-10-17 20:10:37 EDT
mscore is now reporting a segfault when you try to start it, but it's still not working.
Comment 3 Andrew Toskin 2015-11-05 21:09:18 EST
I'm getting a segfault error on my system too (mscore 2.0.1 on Fedora 23).

Trying to run MuseScore in debug mode returns the following message.

> fish: “mscore -d” terminated by signal SIGSEGV (Address boundary error)
Comment 4 Andrew Toskin 2015-11-10 01:27:19 EST
*** Bug 1279718 has been marked as a duplicate of this bug. ***
Comment 5 Andreu Botella 2015-11-12 16:39:16 EST
I also get this error (mscore 2.0.1 on Fedora 23 as well). But when I start it, some of the time it raises a SELinux alert. Though I've got SELinux on permissive mode, so this can't be the only reason for this problem.

The source process: abrt-hook-ccpp
Attempted this access: getattr
On this file: file
Comment 6 Andrew Toskin 2015-11-12 18:20:08 EST
(In reply to Andreu Botella from comment #5)
> The source process: abrt-hook-ccpp
> Attempted this access: getattr
> On this file: file

ABRT is the Automatic Bug Reporting Tool, and gets triggered when programs crash. Your exact SELinux message matches this existing bug report -- https://bugzilla.redhat.com/show_bug.cgi?id=1274963

...but I dunno, "On this file: file" is incredibly vague. It could be related to a bug which more broadly affects SELinux and ABRT -- https://bugzilla.redhat.com/show_bug.cgi?id=1276931

That's my best guess. SELinux has its own bug(s), and in this case, the SELinux Troubleshooter is only coming up because it's reacting inappropriately to MuseScore crashing.

Brendan Jones, what do you think? I'm trying to teach myself about Fedora packaging, and I'd also like to see MuseScore working again. If I could help with testing or something, let me know.
Comment 7 Christoph Karl 2015-11-14 02:11:25 EST
For me also:
>mscore 
Segmentation fault (core dumped)

[and nothing more]

>mscore --help

seems to works
Comment 8 Christoph Karl 2015-11-14 02:16:13 EST
Got the error on two machines:
(both Fedora 23 with all current patches)
4.2.5-300.fc23.x86_64
and
4.2.5-300.fc23.i686+PAE
Comment 9 Brendan Jones 2015-11-14 07:45:55 EST
I believe this is a bug due to font locations, will try and get a build out this weekend
Comment 10 h.siemoneit 2015-11-15 15:03:50 EST
strace shows the missing directory /usr/share/mscore/fonts. A workaround is:
mkdir /usr/share/mscore/ ; ln -s /usr/share/fonts/mscore/ /usr/share/mscore/fonts
Comment 11 Herald van der Breggen 2015-11-16 11:21:44 EST
Yes, this workaround helps. Thanks!
Comment 12 Marco Motta 2015-11-18 11:03:20 EST
*** Bug 1283206 has been marked as a duplicate of this bug. ***
Comment 13 Brendan Jones 2015-11-19 00:59:01 EST
*** Bug 1280446 has been marked as a duplicate of this bug. ***
Comment 14 Brendan Jones 2015-11-19 00:59:22 EST
*** Bug 1278923 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2015-11-19 04:49:31 EST
mscore-2.0.1-6.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5fa4140dec
Comment 16 Fedora Update System 2015-11-19 04:49:32 EST
mscore-2.0.1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-37365fd855
Comment 17 Fedora Update System 2015-11-20 05:22:37 EST
mscore-2.0.1-6.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mscore'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5fa4140dec
Comment 18 Fedora Update System 2015-11-20 06:25:04 EST
mscore-2.0.1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mscore'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-37365fd855
Comment 19 Fedora Update System 2015-11-28 15:22:35 EST
mscore-2.0.1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2015-11-29 01:23:10 EST
mscore-2.0.1-6.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.