Bug 1262535 - sendmail: systemd socket activation support for libmilter
sendmail: systemd socket activation support for libmilter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sendmail (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-12 07:44 EDT by Tomasz Torcz
Modified: 2015-09-23 09:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 09:46:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2015-09-12 07:44:19 EDT
Description of problem:
There's a patch circulating, adding socket activation to libmilter. You can get it from https://bugzilla.suse.com/show_bug.cgi?id=879790

This patch is carried by SUSE, Mageia, Debian/Ubuntu and maybe others. According to SUSE bugreport, it was also submitted upstream.

This patch is not perfect (it hardcodes FD number and does not use LISTEN_FDS) but is good enough. Please apply it to Fedora's package. Thank you.
Comment 1 Jaroslav Škarvada 2015-09-23 09:20:32 EDT
(In reply to Tomasz Torcz from comment #0)
> Description of problem:
> There's a patch circulating, adding socket activation to libmilter. You can
> get it from https://bugzilla.suse.com/show_bug.cgi?id=879790
> 
> This patch is carried by SUSE, Mageia, Debian/Ubuntu and maybe others.
> According to SUSE bugreport, it was also submitted upstream.
> 
> This patch is not perfect (it hardcodes FD number and does not use
> LISTEN_FDS) but is good enough. Please apply it to Fedora's package. Thank
> you.

Thanks for the info. The patch seems to be widespread, thus applying it as is. It seems there are more services hardcoding FD number for socket activation, I think this shouldn't be problem. Also this is more portable change than including systemd headers, thus there may be better chance to be accepted by upstream.

Note You need to log in before you can comment on or make changes to this bug.