Bug 1262541 - CDT Debugger fails to start
CDT Debugger fails to start
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-09-12 10:04 EDT by Christian Stadelmann
Modified: 2015-10-09 18:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: eclipse-cdt-8.6.0-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-10-09 18:21:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Eclipse logfile from ~/fcdtdebugger/ generated on crash (208.35 KB, text/plain)
2015-09-12 10:04 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-09-12 10:04:35 EDT
Created attachment 1072717 [details]
Eclipse logfile from ~/fcdtdebugger/ generated on crash

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
Always. Even with ~/.eclipse, ~/fcdtdebugger and ~/workspace-fcdtdebug deleted.

Steps to Reproduce:
1. try to start `cdtdebug`

Actual results:
Starts, shows splash screen, then a dialog with this text:

An error has occurred. See the log file

Expected results:
It should start fine.

Additional info:
Eclipse with JDT starts fine.

CLI output:
$ cdtdebug 
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dswing.crossplatformlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/eclipse/tycho/core/osgitools/EquinoxResolver.newState
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Comment 1 Christian Stadelmann 2015-09-12 10:31:46 EDT
Sorry, I forgot to add the version:

This exact version worked some time ago, so the issue is not in the eclipse-cdt package itself but somewhere else. But I don't know where to start downgrading packages to hunt down the update that broke it.
Comment 2 Roland Grunberg 2015-09-14 11:02:41 EDT
I can reproduce this as well. javax.el and javax.servlet not being found would seem to be the root cause. The javax.el BSN should be com.sun.el.javax.el, and javax.servlet should be javax.servlet-api. Looks like we need to backport http://pkgs.fedoraproject.org/cgit/eclipse-cdt.git/commit/?id=13e9847bd64362a88bf5ce763e6e52ec8e92e295 to f22.
Comment 3 Roland Grunberg 2015-09-30 10:30:42 EDT
So I backported the set of changes needed. Then I discovered that tycho 0.23 introduced some breaking changes that also needed to be taken into account. Those were fixed. Finally, I ran into compilation errors because a version of eclipse-remote 2.0.0 was in f22-override, which it seems has persisted beyond its expiry : https://github.com/fedora-infra/bodhi/issues/616 .

Once this gets resolved I'll hopefully be able to build.
Comment 4 Fedora Update System 2015-09-30 20:55:09 EDT
eclipse-cdt-8.6.0-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8869e50162
Comment 5 Fedora Update System 2015-10-03 21:37:33 EDT
eclipse-cdt-8.6.0-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update eclipse-cdt'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8869e50162
Comment 6 Fedora Update System 2015-10-09 18:20:58 EDT
eclipse-cdt-8.6.0-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.