Bug 126257 - compiling kernel-2.6.6-1.427 with gcc 3.3.3 fails in function timeval_to_jiffies
compiling kernel-2.6.6-1.427 with gcc 3.3.3 fails in function timeval_to_jiffies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 00:05 EDT by Mark Schlegel
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 19:34:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source dump file (426.70 KB, text/plain)
2004-06-18 00:10 EDT, Mark Schlegel
no flags Details

  None (edit)
Description Mark Schlegel 2004-06-18 00:05:13 EDT
Description of problem:
Compile of kernel-2.6.6-1.427 with gcc 3.3.3 compiler in
Fedora Core 2 fails with seg fault in function 
timeval_to_jiffies. 

Version-Release number of selected component (if applicable):

gcc (GCC) 3.3.3 20040412 (Red Hat Linux 3.3.3-7)
linux-2.6.6-1.427 kernel source via apt-get in FC2

How reproducible:


Steps to Reproduce:
1. installed rpm for kernel 2.6.6-1.427 via apt-get
2. configured .config with make gconfig
3. compile with gcc 3.3.3 with 'make bzImage && make modules'
  
Actual results:
seg faults with console output:
 .............
  CC      arch/i386/kernel/time.o
  CC      arch/i386/kernel/sys_i386.o
  CC      arch/i386/kernel/pci-dma.o
  CC      arch/i386/kernel/i386_ksyms.o
In file included from include/linux/timex.h:186,
                 from include/linux/sched.h:11,
                 from include/linux/module.h:10,
                 from arch/i386/kernel/i386_ksyms.c:2:
include/linux/time.h: In function `timeval_to_jiffies':
include/linux/time.h:261: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccvzgaMU.out file, please attach
this to your bugreport.
make[1]: *** [arch/i386/kernel/i386_ksyms.o] Error 1
make: *** [arch/i386/kernel] Error 2


Expected results:

should make bzImage then continue to make modules as config'ed
in .config

Additional info:

seg fault dumped /tmp/ccvzgaMU.out (see attach)
Comment 1 Mark Schlegel 2004-06-18 00:10:20 EDT
Created attachment 101235 [details]
preprocessed source dump file
Comment 2 Mark Schlegel 2004-06-18 21:34:19 EDT
It seems I can compile fine with CC set to 'gcc32':

setenv CC gcc32; make bzImage && make modules
compiled fine.
I think my bug was a known issue on gcc 3.3 since I
found the suggestion on using gcc32 in a book and
today on the web.

Mark
Comment 3 Greg DeKoenigsberg 2004-06-30 09:45:14 EDT
*** Bug 126301 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2004-10-03 19:34:40 EDT
Compiles just fine with 3.3.4-2 or 3.4.2-2.

Note You need to log in before you can comment on or make changes to this bug.