Bug 1262613 - rtorrent package does NOT work with rutorrent 3.7
rtorrent package does NOT work with rutorrent 3.7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rtorrent (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 08:17 EDT by Roland
Modified: 2015-09-13 13:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-13 11:38:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland 2015-09-13 08:17:52 EDT
Hello

Let me first emphasys that i personally do not have an issue with the package policy of fedora, but, regarding to rutorrent webgui,i want to report something.

My current setup is a fedora 22 server (64bits), as a headless unit.

It does many things for me, and recently i tried to setup an rutorrent server, with all required libs from the repo.

I figured out that i had to install rtorrent and libtorrent.

so i did:

dnf install rtorrent libtorrent [enter]

after that i went to http://server_ip/rutorrent
and the gui appeared.

everyting seems to be working......
when i pressed settings, i got an error about xml rpc
so i installed some libs:
dnf install xmlrpc-c xmlrpc-c-devel [enter]

still the same issue.

after some browsing about this issue, is that rutorrent 3.7 is not able to
work with rtorrent-0.9.4-3.fc22, and libtorrent-0.13.4-3.fc22

i have figured out that the only 2 packages are doing the job, are:

1- rtorrent-0.8.9-1.fc16.x86_64.rpm
2- libtorrent-0.12.9-9.2.x86_64.rpm ( from EL repo )

afer the installation of these 2 packages, rutorrent
is working like a a charm.

I have excluded them for updates as well.

do i overlook something, or am i right, that supplied packages from the repo
are not working with rutorrent?


Kind regards
Comment 1 Conrad Meyer 2015-09-13 11:38:21 EDT
The XMLRPC support in rtorrent 0.9.4 works fine for me.  I haven't tried rutorrent specifically.

> after that i went to http://server_ip/rutorrent
> and the gui appeared.
> 
> everyting seems to be working......

This suggests it was, in fact, working.  Perhaps the protocol has changed and this particular version of rutorrent doesn't work with newer versions of rtorrent.

Since rutorrent isn't a Fedora package, there isn't a lot we can do.
Comment 2 Roland 2015-09-13 13:07:46 EDT
Yes, it works, more or less

you are correct.
the protocol has changed and this particular version of rutorrent doesn't work with newer versions of rtorrent.

My humble question is, what is the point of providing a package that does not work with rutorrent ( 3.7 )?

What other reosons are that rtorrent and libtorrent in the fedora repoś, while it just not works with rutorent, and maybe other packages or so....?

in other words, what additional package, not in fedora repo,  works with
rtorrent and libtorrent from fedora repo?
What webgui works with it??????????
Comment 3 Conrad Meyer 2015-09-13 13:27:44 EDT
rtorrent works by itself, without rutorrent or any webui.

We don't support software outside of the Fedora package repository.  If someone is interested in packaging and maintaining some webUI, great.

Note You need to log in before you can comment on or make changes to this bug.