Bug 126262 - oowriter crashes exporting some documents to ms word format
oowriter crashes exporting some documents to ms word format
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 02:36 EDT by Michael Opdenacker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 12:47:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File that makes ms word export crash (21.09 KB, application/octet-stream)
2004-06-18 02:50 EDT, Michael Opdenacker
no flags Details

  None (edit)
Description Michael Opdenacker 2004-06-18 02:36:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I'm facing an oowriter crash while trying to export
some documents to ms word format.

I get the below dialog box:

"An unrecoverable error has occurred.

All modified files have been saved an can
probably be recovered at program restart."

Here's the error stack that I get in the terminal
used to run oowriter:

---
> oowriter crash.sxw
Error while mapping shared library sections:
: Success.
Error while reading shared library symbols:
: No such file or directory.
 
 
Fatal exception: Signal 11
Stack:
/usr/lib/ooo-1.1/program/libsal.so.3[0x5b77c3]
/usr/lib/ooo-1.1/program/libsal.so.3[0x5b7950]
/usr/lib/ooo-1.1/program/libsal.so.3[0x5b7a19]
[0x8f6420]
/usr/lib/ooo-1.1/program/libsw645li.so[0x56138d7a]
/usr/lib/ooo-1.1/program/libsw645li.so[0x5613902b]
/usr/lib/ooo-1.1/program/libsw645li.so[0x56139d3a]
/usr/lib/ooo-1.1/program/libsw645li.so[0x5613a543]
/usr/lib/ooo-1.1/program/libsw645li.so[0x56106d5a]
/usr/lib/ooo-1.1/program/libsw645li.so[0x56106150]
/usr/lib/ooo-1.1/program/libsw645li.so[0x56047cc8]
/usr/lib/ooo-1.1/program/libsw645li.so[0x561f6b68]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxObjectShell11SaveTo_ImplER9SfxMediumPK10SfxItemSeth+0x10cb)[0x54f3e61]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxObjectShell16PreDoSaveAs_ImplERK6StringS2_P10SfxItemSet+0x3eb)[0x54f9571]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxObjectShell17CommonSaveAs_ImplERK13INetURLObjectRK6StringP10SfxItemSet+0x53f)[0x54f8e3d]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxObjectShell14GUISaveAs_ImplEhP10SfxRequest+0x44ba)[0x55054b2]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxObjectShell13ExecFile_ImplER10SfxRequest+0x1d98)[0x5507592]
/usr/lib/ooo-1.1/program/libsfx645li.so(_Z34SfxStubSfxObjectShellExecFile_ImplP8SfxShellR10SfxRequest+0x26)[0x5500816]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN13SfxDispatcher9Call_ImplER8SfxShellRK7SfxSlotR10SfxRequesth+0x60a)[0x55a1f16]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN13SfxDispatcher8_ExecuteER8SfxShellRK7SfxSlotR10SfxRequestt+0x180)[0x55a3368]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN11SfxBindings12Execute_ImplER10SfxRequestPK7SfxSlotP8SfxShell+0x35c)[0x55b34ba]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN11SfxBindings12Execute_ImplEtPPK11SfxPoolItemttS3_h+0x3d6)[0x55b3090]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN11SfxBindings7ExecuteEtPPK11SfxPoolItemttS3_+0x65)[0x55b2c43]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxVirtualMenu6SelectEP4Menu+0x552)[0x55d02d6]
/usr/lib/ooo-1.1/program/libsfx645li.so(_ZN14SfxVirtualMenu14LinkStubSelectEPvS0_+0x26)[0x55cfd7c]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN4Menu6SelectEv+0x5e)[0x2dea8e]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN4Menu14ImplCallSelectEPS_+0x18)[0x2e286c]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN4Menu22LinkStubImplCallSelectEPvS0_+0x26)[0x2e284c]
/usr/lib/ooo-1.1/program/libvcl645li.so[0x32afae]
/usr/lib/ooo-1.1/program/libvcl645li.so(_Z19ImplWindowFrameProcPvP8SalFrametPKv+0x434)[0x32b806]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN12SalFrameData19HandleClientMessageEP19XClientMessageEvent+0xb3)[0x38cfb1]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN12SalFrameData8DispatchEP7_XEvent+0x5c4)[0x38db66]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN10SalDisplay8DispatchEP7_XEvent+0x2a0)[0x3bbbdc]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN10SalDisplay5YieldEh+0x15b)[0x3bb917]
/usr/lib/ooo-1.1/program/libvcl645li.so[0x3b751f]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN7SalXLib5YieldEh+0x3cb)[0x3b5ed7]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN11SalInstance5YieldEh+0x34)[0x3bf202]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN11Application5YieldEv+0x61)[0x1de6b7]
/usr/lib/ooo-1.1/program/libvcl645li.so(_ZN11Application7ExecuteEv+0x35)[0x1de5c9]
/usr/lib/ooo-1.1/program/soffice.bin(_ZN7desktop7Desktop4MainEv+0x1f1c)[0x8065100]
/usr/lib/ooo-1.1/program/libvcl645li.so(_Z6SVMainv+0x49)[0x1e31f7]
/usr/lib/ooo-1.1/program/libvcl645li.so(main+0x4c)[0x3b48ac]
/lib/tls/libc.so.6(__libc_start_main+0xe4)[0x27a4ad4]
/usr/lib/ooo-1.1/program/soffice.bin(_ZN6Window11RequestHelpERK9HelpEvent+0x31)[0x805ded9]
Aborted
---

Note that this doesn't happen with the 1.1.1 binaries released
by OpenOffice.org (that's a workaround!).

That's why I report this bug to the Fedora
community, not to the OpenOffice.org one.

I will attach one of the documents that causes this to happen.
Note that this doesn't happen with all documents.

Cheers,

Michael.


Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4

How reproducible:
Always

Steps to Reproduce:
1. Run oowriter on the attached .sxw document
2. Save As MS Word 97 / 2000 / XP format.
3. See the crash
    

Additional info:
Comment 1 Michael Opdenacker 2004-06-18 02:50:54 EDT
Created attachment 101239 [details]
File that makes ms word export crash
Comment 2 Dan Williams 2004-06-18 09:05:15 EDT
Confirmed.  All yours Caolan :)
Comment 3 Caolan McNamara 2004-06-21 04:12:38 EDT
Accepted: its http://www.openoffice.org/issues/show_bug.cgi?id=24197
Comment 4 Caolan McNamara 2004-06-21 04:20:19 EDT
Commited changes upstream to ooo-build. openoffice.org 1.1.2 already
contains this fix
Comment 5 Michael Opdenacker 2004-06-21 08:28:10 EDT
Hi Caolan,

Thank you very much for addressing this issue so quickly!
I'm impressed!

Thanks for everything!

:-)

Michael.
Comment 6 Caolan McNamara 2004-08-03 12:47:26 EDT
Works for me in openoffice.org-1.1.2-3 in FC3

Note You need to log in before you can comment on or make changes to this bug.